diff mbox series

[bug#65974,08/33] gnu: Add go-github-com-josharian-native.

Message ID 96c684254cfb22eca414ec9f2811a1daf4fd0e42.1694678168.git.edk@beaver-labs.com
State New
Headers show
Series thirty something go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 8:02 a.m. UTC
* gnu/packages/golang.scm (go-github-com-josharian-native): New variable.
---
 gnu/packages/golang.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8215f29dd5..261c859d27 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13305,6 +13305,27 @@  (define-public go-github-com-hashicorp-go-multierror
 representing a list of @@code{error} values as a single @@code{error}.")
     (license license:mpl2.0)))
 
+(define-public go-github-com-josharian-native
+  (package
+    (name "go-github-com-josharian-native")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/josharian/native")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1wa4yzc3r06qjklqjf4n30zx9v660w8hmxkmybzwk03fmlv2rcyj"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/josharian/native"))
+    (home-page "https://github.com/josharian/native")
+    (synopsis #f)
+    (description "Package native provides easy access to native byte order.")
+    (license license:expat)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")