[bug#78360,v1,1/6] gnu: Switch quazip to qt6.
Commit Message
* gnu/packages/compression.scm (quazip): Link with qt6.
(quazip-5): Inherit from quazip overriding inputs to qt5.
(quazip-0): Inherit from quazip-5 setting version to 0.9.1.
* gnu/packages/admin.scm (corectrl):
* gnu/packages/engineering.scm (librepcb):
* gnu/packages/geo.scm (qmapshack):
* gnu/packages/hardware.scm (ckb-next):
* gnu/packages/ocr.scm (gimagereader):
[inputs]: Rename quazip to quazip-5.
* gnu/packages/password-utils.scm (keepassxc):
[inputs]: Remove unused quazip-0.
Change-Id: I2632560a6795d0825b1b552d79682ed78571cb56
---
gnu/packages/admin.scm | 2 +-
gnu/packages/compression.scm | 53 +++++++++++++++++++--------------
gnu/packages/engineering.scm | 2 +-
gnu/packages/geo.scm | 2 +-
gnu/packages/hardware.scm | 2 +-
gnu/packages/ocr.scm | 2 +-
gnu/packages/password-utils.scm | 1 -
7 files changed, 35 insertions(+), 29 deletions(-)
@@ -3495,7 +3495,7 @@ (define-public corectrl
qtquickcontrols2-5
qtsvg-5
qtwayland-5
- quazip
+ quazip-5
spdlog
trompeloeil
units
@@ -2499,26 +2499,26 @@ (define-public upx
(properties `((lint-hidden-cve . ("CVE-2023-23456" "CVE-2023-23457"))))
(license license:gpl2+)))
-(define-public quazip-0
+(define-public quazip
(package
(name "quazip")
- (version "0.9.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stachenov/quazip")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "11icgwv2xyxhd1hm1add51xv54zwkcqkg85d1xqlgiigvbm196iq"))))
+ (version "1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stachenov/quazip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jsw4xm5wyaqcj1pma5zzd8f5xbgd5lcjh18ah3kg36xz5i69yi4"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ;no test
(native-inputs
(list doxygen))
(inputs
- (list qtbase-5 zlib))
+ (inputs (list qtbase qt5compat zlib)))
(home-page "https://stachenov.github.io/quazip/index.html")
(synopsis "Qt/C++ wrapper for Minizip")
(description "QuaZIP is a simple C++ wrapper over Gilles Vollant's
@@ -2535,20 +2535,27 @@ (define-public quazip-0
;; distributed under zlib terms.
(license (list license:lgpl2.1+ license:zlib))))
-(define-public quazip
+(define-public quazip-5
(package
- (inherit quazip-0)
+ (inherit quazip)
(name "quazip")
(version "1.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stachenov/quazip")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1jsw4xm5wyaqcj1pma5zzd8f5xbgd5lcjh18ah3kg36xz5i69yi4"))))))
+ (inputs (list qtbase-5 zlib))))
+
+(define-public quazip-0
+ (package
+ (inherit quazip-5)
+ (name "quazip")
+ (version "0.9.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stachenov/quazip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11icgwv2xyxhd1hm1add51xv54zwkcqkg85d1xqlgiigvbm196iq"))))))
(define-public zchunk
(package
@@ -2670,7 +2670,7 @@ (define-public librepcb
qtdeclarative-5
qtquickcontrols2-5
qtsvg-5
- quazip
+ quazip-5
zlib))
(native-inputs
(list googletest
@@ -3011,7 +3011,7 @@ (define-public qmapshack
qtlocation-5
qtwebchannel-5
qtwebengine-5
- quazip
+ quazip-5
routino
sqlite ; See wrap phase
zlib))
@@ -530,7 +530,7 @@ (define-public ckb-next
(inputs (list qtbase-5
zlib
libdbusmenu-qt
- quazip
+ quazip-5
pulseaudio
libxcb
xcb-util-wm
@@ -235,7 +235,7 @@ (define-public gimagereader
sane-backends
qtbase-5
qtspell
- quazip
+ quazip-5
tesseract-ocr))
(home-page "https://github.com/manisandro/gImageReader")
(synopsis "Qt front-end to tesseract-ocr")
@@ -305,7 +305,6 @@ (define-public keepassxc
qtsvg-5
qtwayland-5
qtx11extras
- quazip-0 ; XC_KEESHARE
readline
wl-clipboard ;for 'wl-copy'
xclip ;for 'xclip'