diff mbox series

[bug#74259] gnu: Add python-harmonypy.

Message ID 965e7c3c960b7d8808a39c6d50d00dc4a268398f.1731077298.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#74259] gnu: Add python-harmonypy. | expand

Commit Message

Navid Afkhami Nov. 8, 2024, 2:48 p.m. UTC
* gnu/packages/bioinformatics.scm (python-harmonypy): New variable.

Change-Id: Iad8be627099858776163fccfeb27c08129e6fb75
---
 gnu/packages/bioinformatics.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
prerequisite-patch-id: 8f31c5ea3685b59fb6907a9582c0ca537c9c38bd
prerequisite-patch-id: e9f28e6ac20c9572b3cc53ab09c4083161bfdf8d

Comments

Ricardo Wurmus Nov. 11, 2024, 9:53 a.m. UTC | #1
Thanks for the patch.  I moved hatchling to the native inputs because
it's only needed at build time.  I also extended the description a
little bit.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 35ff96ce42..3b393acce2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2397,6 +2397,32 @@  (define-public python-doubletdetection
 from single-cell RNA-sequencing.")
     (license license:expat)))
 
+(define-public python-harmonypy
+  (package
+    (name "python-harmonypy")
+    (version "0.0.10")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/slowkow/harmonypy")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15lxgncrnsx1hapfx78pvx4rjx5d48hqixdnacdy55d84myfmrym"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-hatchling
+                             python-numpy
+                             python-pandas
+                             python-scikit-learn
+                             python-scipy))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/slowkow/harmonypy")
+    (synopsis "Data integration algorithm")
+    (description
+     "Harmony is an algorithm for integrating multiple high-dimensional datasets.")
+    (license license:gpl2)))
+
 (define-public python-hclust2
   (package
     (name "python-hclust2")