diff mbox series

[bug#62191,2/5] gnu: python-debian: Update to 0.1.49.

Message ID 95f5bac48bde535caee2e07bf7f0ab405359eb7c.1678818381.git.mirai@makinata.eu
State New
Headers show
Series gnu: reuse: Update to 1.1.2. | expand

Commit Message

Bruno Victal March 14, 2023, 6:27 p.m. UTC
* gnu/packages/python-xyz.scm (python-debian): Update to 0.1.49.
[native-inputs]: Add python-pytest.
---
 gnu/packages/python-xyz.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4fe84e1eec..f6da4ae9b2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13631,7 +13631,7 @@  (define-public python-debian
   (package
     (name "python-debian")
     (home-page "https://salsa.debian.org/python-debian-team/python-debian")
-    (version "0.1.36")
+    (version "0.1.49")
     (source
      (origin
        ;; Use git-fetch, as pypi doesn't include test suite.
@@ -13642,7 +13642,7 @@  (define-public python-debian
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0qy6x28bj6yfikhjww932v5xq4mf5bm1iczl7acy4c7zm6mwhqfa"))
+         "190vy2ns0650icpwvv4qp6kr3c3i9jszy1vkdwpigxb96fs1bqf3"))
        (modules '((guix build utils)))
        (snippet
         #~(begin
@@ -13658,6 +13658,8 @@  (define-public python-debian
             (substitute* "lib/debian/_version.py"
               (("__CHANGELOG_VERSION__") #$version))))))
     (build-system python-build-system)
+    (native-inputs
+     (list python-pytest))
     (propagated-inputs
      (list python-six python-chardet))
     (synopsis "Debian package related modules")