diff mbox series

[bug#72869] gnu: texlive-digestif: Fix build.

Message ID 95a661ba4df1fe42b81dec1f054d997df60738c5.1724919903.git.adanskana@gmail.com
State New
Headers show
Series [bug#72869] gnu: texlive-digestif: Fix build. | expand

Commit Message

Ada Stevenson Aug. 29, 2024, 8:26 a.m. UTC
* gnu/packages/tex.scm (texlive-digestif):
[arguments]: <#:phases>: Add 'fix-data-path phase.
This hardcodes the path for 'digestif.zip', which was not being found
previously.

Change-Id: I2884185d0daa8919dd72e8b9055eb3988eb40f5d
---
 gnu/packages/tex.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)


base-commit: 53f1d10f089dd1bf155a95d0ba166728498972bb

Comments

Ludovic Courtès Aug. 30, 2024, 8:46 a.m. UTC | #1
Hi Ada,

Ada Stevenson <adanskana@gmail.com> skribis:

> * gnu/packages/tex.scm (texlive-digestif):
> [arguments]: <#:phases>: Add 'fix-data-path phase.
> This hardcodes the path for 'digestif.zip', which was not being found
> previously.
>
> Change-Id: I2884185d0daa8919dd72e8b9055eb3988eb40f5d

Applied on ‘core-updates’ (to be merged real soon) after splitting the
long line.

Thanks!

Ludo’.
Ada Stevenson Aug. 30, 2024, 8:49 a.m. UTC | #2
Hi Ludo',

On 30/08/2024 08:46, Ludovic Courtès <ludo@gnu.org> wrote:
> Hi Ada,
> 
> Ada Stevenson <adanskana@gmail.com> skribis:
> 
> > * gnu/packages/tex.scm (texlive-digestif):
> > [arguments]: <#:phases>: Add 'fix-data-path phase.
> > This hardcodes the path for 'digestif.zip', which was not being found
> > previously.
> >
> > Change-Id: I2884185d0daa8919dd72e8b9055eb3988eb40f5d
> 
> Applied on ‘core-updates’ (to be merged real soon) after splitting the
> long line.

Thank you! And you're welcome :)

> 
> Thanks!
> 
> Ludo’.
> 

Warmly, 

Ada
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 828bcde0e2..b94d1dd67e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33786,7 +33786,14 @@  (define-public texlive-digestif
               "1s7nmbjxpa6klmh0cc6g4s6vd9wmlv4dxp51xb4b872hrj510zbi")))
     (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (arguments (list #:link-scripts #~(list "digestif.texlua")))
+    (arguments (list #:link-scripts #~(list "digestif.texlua")
+                     #:phases
+                     #~(modify-phases %standard-phases
+                         (add-after 'unpack 'fix-data-path
+                           (lambda _
+                             (substitute* "scripts/digestif/digestif.texlua"
+                               (("(local archive = )(.*)$" all beginning end)
+                                (string-append beginning "\"" #$output "/share/texmf-dist/scripts/digestif/digestif.zip\"" "\n"))))))))
     (home-page "https://ctan.org/pkg/digestif")
     (synopsis "Editor plugin for LaTeX, ConTeXt etc.")
     (description