From e0b64a0f8198fb48201c17e9459df8cae1da7a04 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Fri, 15 Jan 2021 05:04:31 -0500
Subject: [PATCH 2/2] gnu: Add nextcloud-client.
* gnu/packages/nextcloud.scm: New module.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* gnu/packages/nextcloud.scm (nextcloud-client): New variable.
---
gnu/local.mk | 1 +
gnu/packages/nextcloud.scm | 158 +++++++++++++++++++++++++++++++++++++
2 files changed, 159 insertions(+)
create mode 100644 gnu/packages/nextcloud.scm
@@ -398,6 +398,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/netpbm.scm \
%D%/packages/nettle.scm \
%D%/packages/networking.scm \
+ %D%/packages/nextcloud.scm \
%D%/packages/nfs.scm \
%D%/packages/nickle.scm \
%D%/packages/nicotine.scm \
new file mode 100644
@@ -0,0 +1,158 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages nextcloud)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages graphviz)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages ruby)
+ #:use-module (gnu packages sphinx)
+ #:use-module (gnu packages sqlite)
+ #:use-module (gnu packages tls)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system qt))
+
+(define-public nextcloud-client
+ (package
+ (name "nextcloud-client")
+ (version "3.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/nextcloud/desktop")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "15ymk3gvfmgwzmqbhlw7jjy9y65ib3391h1dlmpll65iaj2miajk"))
+ (modules '((guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-1)))
+ (snippet
+ `(begin
+ (let ((keep '( ;; Not available in Guix.
+ "QProgressIndicator"
+ "kmessagewidget" "qtlockedfile"
+ "qtokenizer" "qtsingleapplication")))
+ (with-directory-excursion "src/3rdparty"
+ (for-each delete-file-recursively
+ (lset-difference string=?
+ (scandir ".")
+ (cons* "." ".." keep))))
+ #t)))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "-DUNIT_TESTING=ON"
+ ;; Upstream Bug: https://github.com/nextcloud/desktop/issues/2885
+ "-DNO_SHIBBOLETH=ON")
+ #:imported-modules
+ ((guix build glib-or-gtk-build-system)
+ ,@%qt-build-system-modules)
+ #:modules
+ (((guix build glib-or-gtk-build-system)
+ #:prefix glib-or-gtk:)
+ (guix build qt-build-system)
+ (guix build utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-plugin-dirs
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Patch install directory for dbus service files.
+ (substitute* "shell_integration/libcloudproviders/CMakeLists.txt"
+ (("PKGCONFIG_GETVAR\\(.+ _install_dir\\)")
+ "set(_install_dir \"${CMAKE_INSTALL_PREFIX}/share/dbus-1/services\")"))
+ ;; Make sure, that Qt modules are installed under $prefix.
+ (substitute* "shell_integration/dolphin/CMakeLists.txt"
+ (("ON CACHE")
+ "OFF CACHE"))
+ #t))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests write to $HOME.
+ (setenv "HOME" (getcwd))
+ #t))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ (native-inputs
+ `(("cmocka" ,cmocka)
+ ("dot" ,graphviz)
+ ("doxygen" ,doxygen)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("glib:bin" ,glib "bin")
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("qttools" ,qttools)
+ ("ruby" ,ruby)))
+ (inputs
+ `(("appstream" ,appstream)
+ ("glib" ,glib)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kio" ,kio)
+ ("kjs" ,kjs)
+ ("libcloudproviders" ,libcloudproviders)
+ ("libzip" ,libzip)
+ ("openssl" ,openssl)
+ ("python-nautilus" ,python-nautilus)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("qtkeychain" ,qtkeychain)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("qtsvg" ,qtsvg)
+ ("qtwebchannel" ,qtwebchannel)
+ ("qtwebsockets" ,qtwebsockets)
+ ("qtwebkit" ,qtwebkit)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("qtwebengine" ,qtwebengine)))
+ (synopsis "Desktop sync client for Nextcloud")
+ (description "Nextcloud-Desktop is a tool to synchronize files from
+Nextcloud Server with your computer.")
+ (home-page "https://nextcloud.com/install/#install-clients")
+ (license
+ (list
+ ;; QtProgressIndicator
+ license:expat
+ ;; All ThirdParty (except QtProgressIndicator)
+ license:lgpl2.1+
+ ;; Others
+ license:gpl2+))))
--
2.30.1