diff mbox series

[bug#56276,v2,1/2] gnu: Add gdk-pixbuf-xlib.

Message ID 953b0e4bae239733fab4c462c7bc813171ffed01.1656431910.git.tj@schwi.pl
State Accepted
Headers show
Series [bug#56276,v2,1/2] gnu: Add gdk-pixbuf-xlib. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tomasz Jeneralczyk June 28, 2022, 4:15 p.m. UTC
This was part of gtk-pixbuf before but was split into its own library
in version 2.42.0: https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/tags/2.42.0

* gnu/packages/gtk.scm (gtk-pixbuf-xlib): Add variable.
---
 gnu/packages/gtk.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 8d810c209f18ffb635a1db2488a939543c6f060f

Comments

Liliana Marie Prikler July 2, 2022, 11:54 a.m. UTC | #1
Am Dienstag, dem 28.06.2022 um 16:15 +0000 schrieb Tomasz Jeneralczyk:
> This was part of gtk-pixbuf before but was split into its own library
> in version 2.42.0:
> https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/tags/2.42.0
> 
> * gnu/packages/gtk.scm (gtk-pixbuf-xlib): Add variable.
Pushed with a slight rewording, though I missed the typo in gtk-pixbuf-
xlib.  Also added a follow-up commit to hint core-updates folk that the
libx11 input ought to be removed from gdk-pixbuf.

I'll thus mark this as “done”, even if a task remains :)
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4d6a690fbb..358eb365ef 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -717,6 +717,34 @@  (define-public gdk-pixbuf
     (home-page "https://wiki.gnome.org/Projects/GdkPixbuf")
     (license license:lgpl2.1+)))
 
+(define-public gdk-pixbuf-xlib
+  (package
+    (name "gdk-pixbuf-xlib")
+    (version "2.40.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url
+                     "https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vwnvqxap3r9zw932jwasazy9sxw49j78x2g650xkn70iili90bg"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:configure-flags '("-Dgtk_doc=true")))
+    (native-inputs (list pkg-config gtk-doc/stable))
+    (inputs (list gdk-pixbuf libx11))
+    (synopsis "Deprecated Xlib integration for GdkPixbuf")
+    (description
+     "GdkPixbuf-Xlib contains the deprecated API for integrating GdkPixbuf with
+Xlib data types.  This library was originally shipped by gdk-pixbuf, and has
+since been moved out of the original repository.  No newly written code should
+ever use this library.")
+    (home-page "https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib")
+    (license license:lgpl2.1+)))
+
 ;;; A minimal variant used to prevent a cycle with Inkscape.
 (define-public at-spi2-core-minimal
   (hidden-package