diff mbox series

[bug#70147,01/42] gnu: Add rust-age-core-0.10.

Message ID 94f2e26d774bad6c13418bba6bd734a88b6f460b.1712074370.git.w@wmeyer.eu
State New
Headers show
Series WIP: Add rage. | expand

Commit Message

Wilko Meyer April 2, 2024, 4:22 p.m. UTC
* gnu/packages/crates-crypto.scm (rust-age-core-0.10): New variable.

Change-Id: I4385c4b3cb276b8ba333b624b4637436120cb292
---
 gnu/packages/crates-crypto.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index c2497b113b..9111693bf7 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -557,6 +557,36 @@  (define-public rust-aesni-0.6
         ("rust-opaque-debug" ,rust-opaque-debug-0.2)
         ("rust-stream-cipher" ,rust-stream-cipher-0.3))))))
 
+(define-public rust-age-core-0.10
+  (package
+    (name "rust-age-core")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "age-core" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "16shzvisygwknnz4bfs60yfsakwjn4v0rhyvbq9xvg9bpjciiwd5"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-base64" ,rust-base64-0.21)
+                       ("rust-chacha20poly1305" ,rust-chacha20poly1305-0.10)
+                       ("rust-cookie-factory" ,rust-cookie-factory-0.3)
+                       ("rust-hkdf" ,rust-hkdf-0.12)
+                       ("rust-io-tee" ,rust-io-tee-0.1)
+                       ("rust-nom" ,rust-nom-7)
+                       ("rust-rand" ,rust-rand-0.8)
+                       ("rust-secrecy" ,rust-secrecy-0.8)
+                       ("rust-sha2" ,rust-sha2-0.10)
+                       ("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/str4d/rage")
+    (synopsis "Common functions used across the age crates")
+    (description "This package provides common functions used across the age
+crates.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-argon2-0.5
   (package
     (name "rust-argon2")