diff mbox series

[bug#69948,gnome-team,1/3] gnu: Add dbus-1.15.0.

Message ID 94c3c0e5658654ed28786918aa76a97b95c7fb99.1711139684.git.vivien@planete-kraus.eu
State New
Headers show
Series Fix the lightdm testsuite with an older dbus | expand

Commit Message

Vivien Kraus March 22, 2024, 8:30 p.m. UTC
The NEWS file for 1.15.2 (the next release after 1.15.0) indicates a breaking
change.  This is the latest release that the lightdm testsuite can work with.

* gnu/packages/glib.scm (dbus-1.15.0): New variable.

Change-Id: I9c3553b315e6618fbbf19aade6b807ab7120364b
---
 gnu/packages/glib.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index bff8bec81f..cf066a8aa6 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -209,6 +209,21 @@  (define-public dbus-for-jami
                   (("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-local.conf")
                    "/var/run/jami/session-local.conf")))))))))))
 
+(define-public dbus-1.15.0
+  ;; Dbus 1.15.2 has a breaking change.
+  (hidden-package
+   (package/inherit dbus
+     (version "1.15.0")
+     (source (origin
+               (method url-fetch)
+               (uri (string-append
+                     "https://dbus.freedesktop.org/releases/dbus/dbus-"
+                     version ".tar.xz"))
+               (sha256
+                (base32
+                 "02k4zm5h24clwp4csp2r3xp2lxib31jlk3xkgdj2c0njkb5whwsh"))
+               (patches (search-patches "dbus-helper-search-path.patch")))))))
+
 ;;; The reason this is not enabled in the regular dbus package is because it
 ;;; impacts the performance of D-Bus (including its library) as a whole, even
 ;;; when the DBUS_VERBOSE environment variable is not set.