diff mbox series

[bug#41552] gnu: Add remid-lv2.

Message ID 94c136949f58964383c2fabe6a28aa80bc3c79ea.camel@zrythm.org
State Accepted
Headers show
Series [bug#41552] gnu: Add remid-lv2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou May 27, 2020, 12:37 a.m. UTC
Hi,

This patch adds the reMID LV2 plugin.

Thanks,
Alex

Comments

Marius Bakke May 30, 2020, 11:33 a.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi,
>
> This patch adds the reMID LV2 plugin.

Thanks!

[...]

> +(define-public remid-lv2
> +  (package
> +    (name "remid-lv2")
> +    (version "0.3")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append "https://github.com/ssj71/"
> +                            "reMID.lv2/archive/v"
> +                            version ".tar.gz"))

The GitHub /archive/ URLs are not stable: they might fall out of GitHubs
cache and be regenerated, with different time stamps.  So we should use
git-fetch here instead.

This is different from "/releases/", which are uploaded.  Unfortunately
GitHubs UI makes it difficult to tell the difference short of looking at
the URL.

> +        (file-name (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "1kffpv90a967wwpsa0jb1jp5qnhf85m4ap8nfw8wih71rcrgg4h3"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:tests? #f))                      ; no tests included
> +    (inputs
> +     `(("glib" ,glib)
> +       ("alsa-lib" ,alsa-lib)
> +       ("jack" ,jack-1)
> +       ("lv2" ,lv2)))

Nit: we usually sort inputs.  Helpful when there are dozens.

> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)))
> +    (home-page "https://github.com/ssj71/reMID.lv2")
> +    (synopsis
> +      "MIDI-controlled implementation of the SID 6581 chip used in the
> +Commodore 64")
> +    (description
> +      "The 6581 SID chip is the sound chip used in the Commodore 64 computer.
> +reMID is a MIDI implementation of the 6581 SID chip using the reSID library
> +to provide a virtual SID-based synthesizer, controllable in real-time via
> +MIDI.  It includes support for scripted instruments that allow complex sonic
> +control of the chip.")

Why yes, I know some of these words :-) would it make sense to define
"SID" here with @acronym?

> +    (license license:gpl2)))

This is actually GPL2+, because none of the source files say "version 2
only" (and some actually say explicitly GPL2-or-later).

Can you send an updated patch?
diff mbox series

Patch

From ba3a5a3d309e128cd87a4a4b0058b5088f522853 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 27 May 2020 01:35:03 +0100
Subject: [PATCH] gnu: Add remid-lv2.

* gnu/packages/music.scm (remid-lv2): new variable.
---
 gnu/packages/music.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f01978d118..9cfda8e88c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5341,6 +5341,42 @@  hall reverb and a room reverb.  Both are available as LV2 plugins as well
 as JACK standalone applications.")
     (license license:gpl3+)))
 
+(define-public remid-lv2
+  (package
+    (name "remid-lv2")
+    (version "0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://github.com/ssj71/"
+                            "reMID.lv2/archive/v"
+                            version ".tar.gz"))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1kffpv90a967wwpsa0jb1jp5qnhf85m4ap8nfw8wih71rcrgg4h3"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))                      ; no tests included
+    (inputs
+     `(("glib" ,glib)
+       ("alsa-lib" ,alsa-lib)
+       ("jack" ,jack-1)
+       ("lv2" ,lv2)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/ssj71/reMID.lv2")
+    (synopsis
+      "MIDI-controlled implementation of the SID 6581 chip used in the
+Commodore 64")
+    (description
+      "The 6581 SID chip is the sound chip used in the Commodore 64 computer.
+reMID is a MIDI implementation of the 6581 SID chip using the reSID library
+to provide a virtual SID-based synthesizer, controllable in real-time via
+MIDI.  It includes support for scripted instruments that allow complex sonic
+control of the chip.")
+    (license license:gpl2)))
+
 (define-public zlfo
   (package
     (name "zlfo")
-- 
2.26.2