[bug#71780,v3,2/7] gnu: go-github-com-protonmail-go-crypto: Update to 0.0.0-20230923063757-afb1ddc0824c.
Commit Message
* gnu/packages/golang-crypto.scm (go-github-com-protonmail-go-crypto): Update to 0.0.0-20230923063757-afb1ddc0824c.
[inputs]: Add go-github-com-cloudflare-circl.
[format]: Apply 'guix style' to the package
Change-Id: I775c32f7da0e1983c085ddaf24f7767909bdaebc
---
gnu/packages/golang-crypto.scm | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)
@@ -1127,7 +1127,7 @@ (define-public go-github-com-pion-randutil
(define-public go-github-com-protonmail-go-crypto
(package
(name "go-github-com-protonmail-go-crypto")
- (version "0.0.0-20220623141421-5afb4c282135")
+ (version "0.0.0-20230923063757-afb1ddc0824c")
(source
(origin
(method git-fetch)
@@ -1136,20 +1136,21 @@ (define-public go-github-com-protonmail-go-crypto
(commit (go-version->git-ref version))))
(file-name (git-file-name name version))
(sha256
- (base32 "05qxdbn8wdk901z5kw2r3jdrag58nxlcsy0p8xd6rq0d71sw94wy"))))
+ (base32 "11q94983r6zjrdvflpikms4773a9s5vb9gg4qw1rj5800yhhah0n"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/ProtonMail/go-crypto"
- #:tests? #f ; Source-only package.
- #:phases
- #~(modify-phases %standard-phases
- ;; Source-only package.
- (delete 'build))))
- (propagated-inputs
- (list go-golang-org-x-crypto))
+ (list
+ #:import-path "github.com/ProtonMail/go-crypto"
+ #:tests? #f ;Source-only package.
+ #:phases #~(modify-phases %standard-phases
+ ;; Source-only package.
+ (delete 'build))))
+ (propagated-inputs (list go-golang-org-x-crypto
+ go-github-com-cloudflare-circl))
(home-page "https://github.com/ProtonMail/go-crypto")
(synopsis "Fork of x/crypto with up-to-date OpenPGP implementation")
- (description "This package provides cryptography for Go. This version of
+ (description
+ "This package provides cryptography for Go. This version of
the package is a fork that adds a more up-to-date OpenPGP implementation. It
is completely backwards compatible with @code{golang.org/x/crypto}, the
official package.")