diff mbox series

[bug#70337] gnu: Add python-verde.

Message ID 94a4aafd7c7b303d7a9591ca2fd10f495caa60ee.1712828591.git.monego@posteo.net
State New
Headers show
Series [bug#70337] gnu: Add python-verde. | expand

Commit Message

Vinicius Monego April 11, 2024, 9:44 a.m. UTC
* gnu/packages/geo.scm (python-verde): New variable.

Change-Id: I0d176a05a993b19224d22489dd3a8eca19e4f2e0
---
 gnu/packages/geo.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: 51de844a0ff6ea224367a384092896bce6848b9f

Comments

Nicolas Graves April 15, 2024, 9:59 p.m. UTC | #1
user guix
usertag 70337 + reviewed-looks-good
thanks

Guix QA review form submission:
The archival checker is complaining, but it's the only one. 
Otherwise LGTM. 

Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests, New package synopsis and descriptions
Christopher Baines April 16, 2024, 10:15 p.m. UTC | #2
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/geo.scm (python-verde): New variable.
>
> Change-Id: I0d176a05a993b19224d22489dd3a8eca19e4f2e0
> ---
>  gnu/packages/geo.scm | 37 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 37 insertions(+)

Thanks both, I've pushed this to master as
b0fbb70521ff4f6c7cab0bdb9de33edae02f999c.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c30f28d96f..985fa77231 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -105,6 +105,7 @@  (define-module (gnu packages geo)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages machine-learning)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages pcre)
@@ -1388,6 +1389,42 @@  (define-public python-pyshp
       "The Python Shapefile Library (PyShp) reads and writes ESRI Shapefiles.")
     (license license:expat)))
 
+(define-public python-verde
+  (package
+    (name "python-verde")
+    (version "1.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "verde" version))
+       (sha256
+        (base32 "1hnh91dsk2dxfbk7p2hv3hajaa396139pd6apabgdrp5b7s54k97"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; Tests below fetch data remotely.
+     (list #:test-flags #~(list "-k" (string-append
+                                      "not test_minimal_integration_2d_gps"
+                                      " and not test_datasets_locate"
+                                      " and not test_fetch_texas_wind"
+                                      " and not test_fetch_baja_bathymetry"
+                                      " and not test_fetch_rio_magnetic"
+                                      " and not test_fetch_california_gps"))))
+    (native-inputs (list python-cartopy python-distributed))
+    (propagated-inputs (list python-dask
+                             python-numpy
+                             python-pandas
+                             python-pooch
+                             python-scikit-learn
+                             python-scipy
+                             python-xarray))
+    (home-page "https://github.com/fatiando/verde")
+    (synopsis "Processing and gridding spatial data, machine-learning style")
+    (description
+     "Verde is a Python library for processing spatial data (topography, point
+clouds, bathymetry, geophysics surveys, etc) and interpolating them on a 2D
+surface (i.e., gridding) with a hint of machine learning.")
+    (license license:bsd-3)))
+
 (define-public python-cartopy
   (package
     (name "python-cartopy")