[bug#75608] gnu: elixir: Update to 1.18.1.
Commit Message
* gnu/packages/elixir.scm (elixir): Update to 1.18.1.
Change-Id: I3a4d5db3883da8081daeb330345632bd7c2cfcc4
---
gnu/packages/elixir.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
base-commit: 7aae0e2c159b1612b405a372b18f25fbb58f9d82
Comments
Thanks, applied!
What are you thoughts on packaging https://github.com/elixir-lsp/elixir-ls
jgart <jgart@dismail.de> writes:
> Thanks, applied!
Thank you too.
> What are you thoughts on packaging https://github.com/elixir-lsp/elixir-ls
That's a really good idea, I've already thought about it, but I think we
should wait a little bit for the official release of the LSP server, which has
been announced here [1], and it seems to me that it could even be included in
the the main Elixir distribution (like Rust does, but not sure if the Elixir
team will follow that). For now there are three LS: elixir-ls, lexical and
next-ls, each of which is better than the other in some ways, but all of them
will soon become obsolete.
[1]: https://elixir-lang.org/blog/2024/08/15/welcome-elixir-language-server-team/
@@ -9,7 +9,7 @@
;;; Copyright © 2021 Cees de Groot <cg@evrl.com>
;;; Copyright © 2024 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2024 Ivan Sokolov <ivan-p-sokolov@ya.ru>
-;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
+;;; Copyright © 2024, 2025 Igor Goryachev <igor@goryachev.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,7 +41,7 @@ (define-module (gnu packages elixir)
(define-public elixir
(package
(name "elixir")
- (version "1.18.0")
+ (version "1.18.1")
(source
(origin
(method git-fetch)
@@ -50,7 +50,7 @@ (define-public elixir
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ki5wfkdidgkvcm3r6b547gkdpchah4r6z0y96frzf5f3prcjgbx"))
+ (base32 "1bzg3m4dbhvrxv7f20q77j3648j0fkpnmajh4yfz53wj5ail14yc"))
(patches (search-patches "elixir-path-length.patch"))))
(build-system gnu-build-system)
(arguments