[bug#75465] gnu: Add font-cica.

Message ID 94075ba3193cbaa5f1834d135c9cf9cdd78e7451.1736437183.git.rocktakey@gmail.com
State New
Headers
Series [bug#75465] gnu: Add font-cica. |

Commit Message

ROCKTAKEY Jan. 9, 2025, 3:46 p.m. UTC
  Change-Id: I8bfd7f7050d8e6870aeb3e5f65f8b420078170ef
---
 gnu/packages/fonts.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 981af9992881b7395692bd6233722464d173a51f
  

Comments

宋文武 Jan. 13, 2025, 12:23 a.m. UTC | #1
Pushed to master, thank you!
  

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 69d7d039aa..bbd9cc4d10 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3893,3 +3893,28 @@  (define-public font-dina
 It is relatively compact to allow a lot of code on screen, while (hopefully) clear
 enough to remain readable even at high resolutions.")
     (license license:expat)))
+
+(define-public font-cica
+  (package
+    (name "font-cica")
+    (version "5.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/miiton/Cica/releases/download/"
+             "v"
+             version
+             "/Cica_v"
+             version
+             ".zip"))
+       (sha256
+        (base32 "0vshn2cd70mnbavsw9cbagcasa95wiv9qdj4wkzxn7gxygqvrlfb"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/miiton/Cica")
+    (synopsis "Japanese monospaced font for programming")
+    (description
+     "Cica is a Japanese monospaced font for programming.
+Hack + DejaVu Sans Mono is used for ASCII, and Rounded Mgen+ for the other.
+In addition, Nerd Fonts, Noto Emoji, Icons for Devs, and some adjustment forked from
+the Ricty generator are converted and adjusted.")
+    (license license:silofl1.1)))