[bug#33526] Utilities for emacs-irony-mode

Message ID 94000ce9-c70c-ed74-a4e7-5911def116c8@yahoo.de
State Accepted
Headers show
Series [bug#33526] Utilities for emacs-irony-mode | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Tim Gesthuizen Nov. 27, 2018, 5:13 p.m. UTC
Hi,
I added some extra packages for using emacs-irony-mode and updated it
to fetch sources from git.
These packages should enhance integration of emacs-irony-mode into emacs.

Tim.

Comments

Ludovic Courtès Nov. 29, 2018, 8:48 a.m. UTC | #1
Hello,

Tim Gesthuizen <tim.gesthuizen@yahoo.de> skribis:

> From be0733336aaf0047f92eaccb6cb360c86f941298 Mon Sep 17 00:00:00 2001
> From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
> Date: Tue, 27 Nov 2018 17:56:33 +0100
> Subject: [PATCH 1/4] gnu: Add emacs-company-irony.
>
> * gnu/packages/emacs.scm (emacs-company-irony): New variable.

I fixed the tiny issues reported by ‘guix lint’, made the description a
full sentence (info "(guix) Synopses and Descriptions"), and committed.

> From bf04fa3e0892bd9461feb5bebb7454f478710282 Mon Sep 17 00:00:00 2001
> From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
> Date: Tue, 27 Nov 2018 17:57:14 +0100
> Subject: [PATCH 2/4] gnu: Add emacs-flycheck-irony.
>
> * gnu/packages/emacs.scm (emacs-flycheck-irony): New variable.

[...]

> +	      (method git-fetch)
> +	      (uri (git-reference
> +		    (url "https://github.com/Sarcasm/flycheck-irony.git")
> +		    (commit version)))

The tag should be “v1.0.0”, not “1.0.0”, but then the hash is different
than the one here.

Also, ‘guix lint’ reports the same kind of issues as above.

Could you double-check and adjust the Git references and address the
issues that ‘guix lint’ reports in the remaining patches?

Thank you!

Ludo’.

Patch

From a1139fb9db8b1de48b6a6a4e3679a60a7e7e9bd5 Mon Sep 17 00:00:00 2001
From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
Date: Tue, 27 Nov 2018 18:09:25 +0100
Subject: [PATCH 4/4] gnu: emacs-irony-mode: Fetch source using git.

* gnu/packages/emacs.scm (emacs-irony-mode)[source]: Rewrite in terms of GIT-FETCH.
---
 gnu/packages/emacs.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 45f0e1060..e73766834 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2811,11 +2811,13 @@  These are distributed in separate files and can be used individually.")
     (version "1.2.0")
     (home-page "https://github.com/Sarcasm/irony-mode")
     (source (origin
-              (method url-fetch)
-              (uri (string-append home-page "/archive/v" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url (string-append home-page ".git"))
+                    (commit (string-append "v" version))))
               (sha256
                (base32
-                "1f68zi0glkg2aly66s07rx3w0b0hdi1znxan02h6dbabaadylk99"))
+                "0nhjrnlmss535jbshjjd30vydbr8py21vkx4p294w6d8vg2rssf8"))
               (file-name (string-append name "-" version ".tar.gz"))))
     (build-system emacs-build-system)
     (arguments '())
-- 
2.19.2