diff mbox series

[bug#69736,v2,2/6] gnu: Add python-addict.

Message ID 93f6c8615c12e117d1b30fc3b23bb6222188318d.1720019008.git.arunisaac@systemreboot.net
State New
Headers show
Series [bug#69736,v2,1/6] gnu: Add python-pypubsub. | expand

Commit Message

Arun Isaac July 3, 2024, 3:07 p.m. UTC
* gnu/packages/python-xyz.scm (python-addict): New variable.

Change-Id: I1554d17495bf9337067422f2118f8b46e51abead
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 328750b38b..06453709de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23841,6 +23841,23 @@  (define-public python-attrdict3
 both as keys and as attributes.")
     (license license:expat)))
 
+(define-public python-addict
+  (package
+    (name "python-addict")
+    (version "2.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "addict" version))
+              (sha256
+               (base32
+                "1574sicy5ydx9pvva3lbx8qp56z9jbdwbj26aqgjhyh61q723cmk"))))
+    (build-system pyproject-build-system)
+    (home-page "https://github.com/mewwts/addict")
+    (synopsis "Python dictionary with attribute accessible values")
+    (description "@code{python-addict} provides dictionaries whose items can
+be get and set using both attribute and item syntax.")
+    (license license:expat)))
+
 (define-public python-attrs
   (package
     (name "python-attrs")