diff mbox series

[bug#48466] gnu: notmuch: Update to 0.32.1.

Message ID 93cf51a9d6c704c3b815725358c12b76e956d25c.1621174080.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#48466] gnu: notmuch: Update to 0.32.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen May 16, 2021, 2:08 p.m. UTC
* gnu/packages/mail.scm (notmuch): Update to 0.32.1.
[arguments]<#:phases>: Don’t return #t at the end of the phase, this won’t be
necessary once core-update gets merged.
---
 gnu/packages/mail.scm | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)


base-commit: 7c4c781aa40c42d4cd10b8d9482199f3db345e1b

Comments

Marius Bakke May 23, 2021, 2:34 p.m. UTC | #1
Xinglu Chen <public@yoctocell.xyz> skriver:

> * gnu/packages/mail.scm (notmuch): Update to 0.32.1.
> [arguments]<#:phases>: Don’t return #t at the end of the phase, this won’t be
> necessary once core-update gets merged.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index db42b2a309..64c94b654c 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1331,14 +1331,14 @@  invoking @command{notifymuch} from the post-new hook.")
 (define-public notmuch
   (package
     (name "notmuch")
-    (version "0.31.4")
+    (version "0.32.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://notmuchmail.org/releases/notmuch-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "0magnyjjhhv11nwcm2596hdxszrj61y69i0hmwqdc3v6cxjvcqc6"))))
+                "0586d13ssygapjdri4cl25wzywivwsbxpjm6xlgxj6f9ii7clix7"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)
@@ -1354,8 +1354,7 @@  invoking @command{notifymuch} from the post-new hook.")
                   (add-after 'unpack 'patch-notmuch-lib.el
                     (lambda _
                       (substitute* "emacs/notmuch-lib.el"
-                        (("/bin/sh") (which "sh")))
-                      #t))
+                        (("/bin/sh") (which "sh")))))
                   (replace 'configure
                     (lambda* (#:key outputs #:allow-other-keys)
                       (setenv "CC" "gcc")
@@ -1372,15 +1371,13 @@  invoking @command{notifymuch} from the post-new hook.")
                     ;; and try removing this for notmuch versions > 0.31.
                     (lambda _
                       (substitute* "test/T356-protected-headers.sh"
-                        (("\\$NOTMUCH_GMIME_X509_CERT_VALIDITY") "0"))
-                      #t))
+                        (("\\$NOTMUCH_GMIME_X509_CERT_VALIDITY") "0"))))
                   (add-before 'check 'prepare-test-environment
                     (lambda _
                       (setenv "TEST_CC" "gcc")
                       ;; Patch various inline shell invocations.
                       (substitute* (find-files "test" "\\.sh$")
-                        (("/bin/sh") (which "sh")))
-                      #t))
+                        (("/bin/sh") (which "sh")))))
                   (add-after 'install 'make-autoloads
                     (assoc-ref emacs:%standard-phases 'make-autoloads)))))
     (native-inputs