diff mbox series

[bug#38850] Fix GNOME Characters

Message ID 93831577876389@myt3-a8f6b0e91bb2.qloud-c.yandex.net
State Accepted
Headers show
Series [bug#38850] Fix GNOME Characters | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ivan Kozlov Jan. 1, 2020, 10:59 a.m. UTC
GNOME Characters needs Typelib files from GTK and gnome-desktop.

---
 gnu/packages/gnome.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Jan. 6, 2020, 2:34 p.m. UTC | #1
kanichos@yandex.ru skribis:

> GNOME Characters needs Typelib files from GTK and gnome-desktop.
>
> ---
>  gnu/packages/gnome.scm | 11 +++++++++--
>  1 file changed, 9 insertions(+), 2 deletions(-)

Applied with changes similar to the previous patch.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ad3e78c284..fd21b577c0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -494,7 +494,13 @@  to other formats.")
         (base32
          "08cwz39iwgsyyb2wqhb8vfbmh1cwfkgfiy7adp08w7rwqi99x3dp"))))
     (build-system meson-build-system)
-    (arguments '(#:glib-or-gtk? #t))
+    (arguments `(#:glib-or-gtk? #t
+                 #:phases (modify-phases %standard-phases
+                            (add-after 'install 'wrap
+                              (lambda* (#:key outputs #:allow-other-keys)
+                                (wrap-program (string-append (assoc-ref outputs "out") "/bin/gnome-characters")
+                                  `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
+                                #t)))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin")
@@ -504,7 +510,8 @@  to other formats.")
     (inputs
      `(("gjs" ,gjs)
        ("gtk+" ,gtk+)
-       ("libunistring" ,libunistring)))
+       ("libunistring" ,libunistring)
+       ("gnome-desktop" ,gnome-desktop)))
     (home-page "https://wiki.gnome.org/Apps/CharacterMap")
     (synopsis "Find and insert unusual characters")
     (description "Characters is a simple utility application to find