diff mbox series

[bug#61226,v2,2/2] gnu: xdg-utils: Use a pinned version of w3m.

Message ID 935e58c604d205cf0178cefb04e5508b8530422c.1675437676.git.leo@famulari.name
State New
Headers show
Series [bug#61226,v2,1/2] gnu: Add a pinned-version variant of w3m. | expand

Commit Message

Leo Famulari Feb. 3, 2023, 3:21 p.m. UTC
* gnu/packages/freedesktop.scm (xdg-utils)[native-inputs]: Replace w3m with
w3m-for-tests.
[arguments]: Use #:disallowed-references to prevent keeping a reference to
w3m-for-tests.
---
 gnu/packages/freedesktop.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Maxim Cournoyer Feb. 9, 2023, 4:06 a.m. UTC | #1
Hi,

Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/freedesktop.scm (xdg-utils)[native-inputs]: Replace w3m with
> w3m-for-tests.
> [arguments]: Use #:disallowed-references to prevent keeping a reference to
> w3m-for-tests.
> ---
>  gnu/packages/freedesktop.scm | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index a986c8c350..677ab5fdf2 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -482,7 +482,7 @@ (define-public xdg-utils
>               "1nai806smz3zcb2l5iny4x7li0fak0rzmjg6vlyhdqm8z25b166p"))))
>      (build-system gnu-build-system)
>      (native-inputs
> -     (list docbook-xsl docbook-xml-4.1.2 libxslt w3m xmlto))
> +     (list docbook-xsl docbook-xml-4.1.2 libxslt w3m-for-tests xmlto))
>      (inputs
>       `(("awk" ,gawk)
>         ;; TODO(staging): Make this unconditional, to avoid canonical packages,
> @@ -501,7 +501,9 @@ (define-public xdg-utils
>         ("xprop" ,xprop) ; for Xfce detecting
>         ("xset" ,xset))) ; for xdg-screensaver
>      (arguments
> -     `(#:tests? #f   ; no check target
> +     `(; Ensure we don't keep a reference to this old version of w3m

I was confused by the "old version".  Perhaps rephrase to "[...] this
potentially old version [...]" ?

> +       #:disallowed-references (,w3m-for-tests)
> +       #:tests? #f   ; no check target
>         #:modules ((srfi srfi-26)
>                    ,@%gnu-build-system-modules)
>         #:phases

Otherwise, LGTM!
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a986c8c350..677ab5fdf2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -482,7 +482,7 @@  (define-public xdg-utils
              "1nai806smz3zcb2l5iny4x7li0fak0rzmjg6vlyhdqm8z25b166p"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list docbook-xsl docbook-xml-4.1.2 libxslt w3m xmlto))
+     (list docbook-xsl docbook-xml-4.1.2 libxslt w3m-for-tests xmlto))
     (inputs
      `(("awk" ,gawk)
        ;; TODO(staging): Make this unconditional, to avoid canonical packages,
@@ -501,7 +501,9 @@  (define-public xdg-utils
        ("xprop" ,xprop) ; for Xfce detecting
        ("xset" ,xset))) ; for xdg-screensaver
     (arguments
-     `(#:tests? #f   ; no check target
+     `(; Ensure we don't keep a reference to this old version of w3m
+       #:disallowed-references (,w3m-for-tests)
+       #:tests? #f   ; no check target
        #:modules ((srfi srfi-26)
                   ,@%gnu-build-system-modules)
        #:phases