diff mbox series

[bug#66214] gnu: psautohint: Disable flaky tests.

Message ID 93558a4525060f2d52b469ef3098456f14c17dc3.1695740785.git.hako@ultrarare.space
State New
Headers show
Series [bug#66214] gnu: psautohint: Disable flaky tests. | expand

Commit Message

Hilton Chain Sept. 26, 2023, 3:08 p.m. UTC
* gnu/packages/fontutils.scm (psautohint)[#:test-flags]: Disable tests
test_hashmap_no_version and test_hashmap_old_version.
---
 gnu/packages/fontutils.scm | 15 ++++++++++++---
 1 file changed, 12 insertions(+), 3 deletions(-)


base-commit: b2887da40c6cb9d541a9df67aa726694f64d8943

Comments

Tobias Geerinckx-Rice Sept. 29, 2023, 9:10 p.m. UTC | #1
Ohai,

On 2023-09-26 17:08, Hilton Chain via Guix-patches via wrote:
> * gnu/packages/fontutils.scm (psautohint)[#:test-flags]: Disable tests
> test_hashmap_no_version and test_hashmap_old_version.

Pushed to master as b268842ec4808f5030f3bda95f52ff39dd88e3ad with a 
minor commit message tweak ([#:test-flags] → [arguments]).

Thanks,

T G-R

Sent from a Web browser.  Excuse or enjoy my brevity.
diff mbox series

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 18697cd821..c781ae2baf 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -789,9 +789,18 @@  (define-public psautohint
     (build-system pyproject-build-system)
     (arguments
      (list
-      ;; The CJKSparseVar.subset.hinted.otf test fails with slightly different
-      ;; output caused by the newer fonttools version used in Guix.
-      #:test-flags #~(list "-k" "not CJKSparseVar.subset.hinted.otf")
+      #:test-flags
+      #~(list "-k"
+              (string-join
+               '(;; The CJKSparseVar.subset.hinted.otf test fails with slightly
+                 ;; different output caused by the newer fonttools version used
+                 ;; in Guix.
+                 "not CJKSparseVar.subset.hinted.otf"
+                 ;; These tests fails underministically, See also:
+                 ;; https://github.com/adobe-type-tools/afdko/issues/1678
+                 "not test_hashmap_no_version"
+                 "not test_hashmap_old_version")
+               " and "))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'copy-font-data