diff mbox series

[bug#57671] gnu: Add mpdevil.

Message ID 932cec629b2a3cdc01d2eb006eead634b3fd417f.camel@gmail.com
State Accepted
Headers show
Series [bug#57671] gnu: Add mpdevil. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Liliana Marie Prikler Sept. 8, 2022, 8:48 a.m. UTC
* gnu/packages/mpd.scm (mpdevil): New variable.
---
 gnu/packages/mpd.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Christopher Baines Sept. 10, 2022, 9:50 a.m. UTC | #1
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/mpd.scm (mpdevil): New variable.
> ---
>  gnu/packages/mpd.scm | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)

There's one lint warning that can be fixed, but apart from that this
looks good to me.

> diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
> index 046471f32d..c7d9b4646c 100644
> --- a/gnu/packages/mpd.scm
> +++ b/gnu/packages/mpd.scm
> @@ -523,3 +523,38 @@ (define-public mcg
>  album-experience.")
>      (home-page "https://gitlab.com/coderkun/mcg")
>      (license license:gpl3+)))
> +
> +(define-public mpdevil
> +  (package
> +    (name "mpdevil")
> +    (version "1.7.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/SoongNoonien/mpdevil")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32 "1va8fqlz8qb68gvacnzmp4asnipi11316n1cv2wb41sml9d7v00j"))))
> +    (build-system meson-build-system)
> +    (arguments
> +     (list
> +      #:glib-or-gtk? #t
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
> +            (lambda* (#:key outputs #:allow-other-keys)
> +              (let ((prog (string-append (assoc-ref outputs "out")
> +                                         "/bin/mpdevil")))
> +                (wrap-program prog
> +                  `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
> +                  `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))

The linter says:

  "bash-minimal" should be in 'inputs' when 'wrap-program' is used

> +    (inputs (list gtk+ python python-mpd2 python-pygobject))
> +    (native-inputs (list `(,glib "bin")))
> +    (home-page "https://github.com/SoongNoonien/mpdevil")
> +    (synopsis "Music browser for the MPD")
> +    (description "mpdevil is a music browser for the Music Player Daemon (MPD),
> +which is focused on playing local music without the need of managing playlists.
> +Instead of maintaining a client side database of your music library,
> +mpdevil loads all tags and covers on demand.")
> +    (license license:gpl3+)))
\( Sept. 10, 2022, 9:57 a.m. UTC | #2
Hey Liliana,

On Thu Sep 8, 2022 at 9:48 AM BST, Liliana Marie Prikler wrote:
> +    (arguments
> +     (list
> +      #:glib-or-gtk? #t

Maybe move these keywords like this:

  (list #:glib-or-gtk? #t
        #:phases
        #~(...))

This generally seems to be the standard.

> +            (lambda* (#:key outputs #:allow-other-keys)
> +              (let ((prog (string-append (assoc-ref outputs "out")
> +                                         "/bin/mpdevil")))

`(assoc-ref outputs "out")' -> `#$output'
`(lambda* (#:key outputs #:allow-other-keys)' -> `(lambda _'

> +    (native-inputs (list `(,glib "bin")))

``(,glib "bin")' -> `(list glib "bin")'

> +    (description "mpdevil is a music browser for the Music Player Daemon (MPD),

This:

  (description
   "...")

seems to be the norm for descriptions.

    -- (
Liliana Marie Prikler Sept. 10, 2022, 3:25 p.m. UTC | #3
Am Samstag, dem 10.09.2022 um 10:50 +0100 schrieb Christopher Baines:
> The linter says:
> 
>   "bash-minimal" should be in 'inputs' when 'wrap-program' is used
Fixed and pushed.
diff mbox series

Patch

diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 046471f32d..c7d9b4646c 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -523,3 +523,38 @@  (define-public mcg
 album-experience.")
     (home-page "https://gitlab.com/coderkun/mcg")
     (license license:gpl3+)))
+
+(define-public mpdevil
+  (package
+    (name "mpdevil")
+    (version "1.7.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/SoongNoonien/mpdevil")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1va8fqlz8qb68gvacnzmp4asnipi11316n1cv2wb41sml9d7v00j"))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let ((prog (string-append (assoc-ref outputs "out")
+                                         "/bin/mpdevil")))
+                (wrap-program prog
+                  `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
+                  `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
+    (inputs (list gtk+ python python-mpd2 python-pygobject))
+    (native-inputs (list `(,glib "bin")))
+    (home-page "https://github.com/SoongNoonien/mpdevil")
+    (synopsis "Music browser for the MPD")
+    (description "mpdevil is a music browser for the Music Player Daemon (MPD),
+which is focused on playing local music without the need of managing playlists.
+Instead of maintaining a client side database of your music library,
+mpdevil loads all tags and covers on demand.")
+    (license license:gpl3+)))