diff mbox series

[bug#63486,v2,1/3] gnu: python-txtorcon: Fix failing build.

Message ID 93293536c55245718d7245b0334bc73d3609a96f.1683999057.git.juli@incana.org
State New
Headers show
Series [bug#63486,v2,1/3] gnu: python-txtorcon: Fix failing build. | expand

Commit Message

Juliana Sims May 13, 2023, 5:31 p.m. UTC
Oops, I forgot to add a copyright line - this version fixes that.

* gnu/packages/python-crypto.scm (python-txtorcon): Fix failing build.
---
 gnu/packages/python-crypto.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)


base-commit: ed1e7920393c9ae5b2ae31fc46bae88136239b13
diff mbox series

Patch

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index b1d94e85b8..be3ab5d0be 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
+;;; Copyright © 2023 Juliana Sims <juli@incana.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1253,7 +1254,12 @@  (define-public python-txtorcon
         (uri (pypi-uri "txtorcon" version))
         (sha256
          (base32
-          "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))))
+          "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))
+        (modules '((guix build utils)))
+        (snippet
+         #~(substitute* "txtorcon/controller.py"
+             (("from collections import Sequence")
+              "from collections.abc import Sequence")))))
     (build-system python-build-system)
     (arguments
       ;; The tests fail immediately due to a missing file. Reported upstream: