[bug#33334] :gnu:add ne:the nice editor

Message ID 92c80aefcd1dd8a6ddf25c1db4606b368bc37e17.camel@gmail.com
State Accepted
Headers show
Series [bug#33334] :gnu:add ne:the nice editor | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

guy fleury iteriteka Nov. 11, 2018, 2:23 p.m. UTC
Le samedi 10 novembre 2018 à 22:20 +0100, swedebugia a écrit :
> Hi :)
> Did you run ./pre-inst-env guix lint on the package?
> It has trailing whitespaces in two places.
------------------------------------------------------
./pre-inst-env guix lint ne
gnu/packages/nano.scm:85:7: ne@3.1.2: sentences in description should
be followed by two spaces; possible infraction at 78
accepted connection from pid 16902, user guy
gnu/packages/nano.scm:83:14: ne@3.1.2: synopsis should start with an
upper-case letter or digit
gnu/packages/nano.scm:83:14: ne@3.1.2: synopsis should not start with
the package name
guix lint: warning: while retrieving CVE vulnerabilities: TLS
certificate error: X.509 certificate of 'nvd.nist.gov' could not be
verified:
  signer-not-found
  invalid

gnu/packages/nano.scm:56:2: ne@3.1.2: trailing white space on line 80
gnu/packages/nano.scm:56:2: ne@3.1.2: trailing white space on line 85
gnu/packages/nano.scm:56:2: ne@3.1.2: trailing white space on line 86
gnu/packages/nano.scm:56:2: ne@3.1.2: trailing white space on line 87
-----------------------------------------------------------------------
i failed to indent well.Perphaps you can do it.it compiles quickly.
yes i know,i got soon learn to indent.
> On 2018-11-10 10:25, guy fleury wrote:
> > hi all,
> > 
> > i have packaged: ne "the nice editor".
> > it is my first tempt to contribute to any project,if i do things
> > wrong
> > tell me with additionnal informations!
> 
> Thank you! Me too. I submitted my first patch ever to Guix a few
> days 
> ago. :)
> 
> > 0001-gnu-add-ne-the-nice-editor.patch
> > 
> >  From 1ec45eaa225e7203a98b36cddb7d42db418b773b Mon Sep 17 00:00:00
> > 2001
> > From: guy fleury<hoonandon@gmail.com>
> > Date: Sat, 10 Nov 2018 10:51:17 +0200
> > Subject: [PATCH] gnu:add ne:the nice editor
> 
> snip
> 
> > +    (build-system gnu-build-system)
> > +    (arguments
> > +       `(#:tests? #f
> 
> Could you please explain why the tests are disabled?
> Search the packages to see examples of explanations.
> 
> > +          #:make-flags (list (string-append "PREFIX=" (assoc-ref
> > %outputs "out"))
> > +                   "CC=gcc")
> > +         #:parallel-build? #f
> > +         #:phases (modify-phases %standard-phases
> > +                                 (delete 'configure))))
> 
> Same here. Please explain.
> 
> Tested the compilation and ran the editor. Seemed nice!
> 
> Maybe this could complement nano if it highlights scheme and has a
> macro 
> to help with e.g. finding missing parens.
i did that.
it not supports highlights scheme but show missing parens.
it supports also highlights in other languages(such c,c++,etc)
> Could you send an updated patch?

yes,here is my patch updated.

Patch

From 5cbedbd432a7dc97d6474fc7291f9da5adfe8f47 Mon Sep 17 00:00:00 2001
From: guy fleury <hoonandon@gmail.com>
Date: Sun, 11 Nov 2018 14:51:11 +0200
Subject: [PATCH] gnu:Add ne:A nice editor

---
 gnu/packages/nano.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/nano.scm b/gnu/packages/nano.scm
index 8f96b605a..dafdf6537 100644
--- a/gnu/packages/nano.scm
+++ b/gnu/packages/nano.scm
@@ -51,3 +51,39 @@  basic editing, it supports: undo/redo, syntax highlighting, spell checking,
 justifying, auto-indentation, bracket matching, interactive search-and-replace
 (with regular expressions), and the editing of multiple files.")
     (license gpl3+))) ; some files are under GPLv2+
+
+(define-public ne
+  (package
+    (name "ne")
+    (version "3.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://ne.di.unimi.it/ne-" version
+                                  ".tar.gz"))
+              (sha256
+               (base32
+                "06qk3cqxyn098i1yn686bigpgh8vrrnj0qpkrgs6zwnq42s1y0d2"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; use lncurses instead of lcurses
+               '(begin
+                  (substitute* "src/makefile"
+                    (("-lcurses")
+                     "-lncurses"))
+                  #t))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ;; no test suite avaliable
+       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                          "CC=gcc")
+       ;;we don't need configure
+       #:phases (modify-phases %standard-phases (delete 'configure))))   
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (synopsis "ne, A nice editor")
+    (description
+       "ne is fast,small,powerful and simple text editor that can be fully 
+configured. It has a simple scripting language where scripts can be easily 
+generated and played") 
+    (home-page "http://ne.di.unimi.it/ne")
+    (license gpl3+)))
-- 
2.19.0