From 5cbedbd432a7dc97d6474fc7291f9da5adfe8f47 Mon Sep 17 00:00:00 2001
From: guy fleury <hoonandon@gmail.com>
Date: Sun, 11 Nov 2018 14:51:11 +0200
Subject: [PATCH] gnu:Add ne:A nice editor
---
gnu/packages/nano.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
@@ -51,3 +51,39 @@ basic editing, it supports: undo/redo, syntax highlighting, spell checking,
justifying, auto-indentation, bracket matching, interactive search-and-replace
(with regular expressions), and the editing of multiple files.")
(license gpl3+))) ; some files are under GPLv2+
+
+(define-public ne
+ (package
+ (name "ne")
+ (version "3.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://ne.di.unimi.it/ne-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "06qk3cqxyn098i1yn686bigpgh8vrrnj0qpkrgs6zwnq42s1y0d2"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; use lncurses instead of lcurses
+ '(begin
+ (substitute* "src/makefile"
+ (("-lcurses")
+ "-lncurses"))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;; no test suite avaliable
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ ;;we don't need configure
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (synopsis "ne, A nice editor")
+ (description
+ "ne is fast,small,powerful and simple text editor that can be fully
+configured. It has a simple scripting language where scripts can be easily
+generated and played")
+ (home-page "http://ne.di.unimi.it/ne")
+ (license gpl3+)))
--
2.19.0