[bug#53523,v2,2/2] gnu: neovim: Update to 0.6.1.
Commit Message
* gnu/packages/vim.scm (neovim): Update to 0.6.1.
Build neovim with LuaJIT in the supported platforms.
---
gnu/packages/vim.scm | 21 ++++++++++++++++-----
1 file changed, 16 insertions(+), 5 deletions(-)
Comments
Luis Henrique Gomes Higino schreef op di 01-02-2022 om 10:04 [-0300]:
> + #:configure-flags
> + (list ,@(if (member (or (%current-target-system)
> + (%current-system))
> + (package-supported-systems luajit))
This does not work, (%current-target-system) is a GNU triplet
whereas (%current-system) is a nix system, see
<https://issues.guix.gnu.org/49672>
Greetings,
Maxime.
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Tissevert <tissevert+guix@marvid.fr>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -661,7 +662,7 @@ (define-public neovim-syntastic
(define-public neovim
(package
(name "neovim")
- (version "0.4.4")
+ (version "0.6.1")
(source
(origin
(method git-fetch)
@@ -670,13 +671,18 @@ (define-public neovim
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11zyj6jvkwas3n6w1ckj3pk6jf81z1g7ngg4smmwm7c27y2a6f2m"))))
+ (base32 "10p6lg5yv9n6wcwdprwvvi56dfcm4wsj54nm0invyx3mhf7374lx"))))
(build-system cmake-build-system)
(arguments
`(#:modules ((srfi srfi-26)
(guix build cmake-build-system)
(guix build utils))
- #:configure-flags '("-DPREFER_LUA:BOOL=YES")
+ #:configure-flags
+ (list ,@(if (member (or (%current-target-system)
+ (%current-system))
+ (package-supported-systems luajit))
+ '()
+ '("-DPREFER_LUA:BOOL=YES")))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-lua-paths
@@ -717,11 +723,16 @@ (define-public neovim
("unibilium" ,unibilium)
("jemalloc" ,jemalloc)
("libiconv" ,libiconv)
- ("lua" ,lua-5.1)
+ ("lua" ,(if (member (or (%current-target-system)
+ (%current-system))
+ (package-supported-systems luajit))
+ luajit
+ lua-5.1))
("lua-luv" ,lua5.1-luv)
("lua-lpeg" ,lua5.1-lpeg)
("lua-bitop" ,lua5.1-bitop)
- ("lua-libmpack" ,lua5.1-libmpack)))
+ ("lua-libmpack" ,lua5.1-libmpack)
+ ("tree-sitter" ,tree-sitter)))
(native-inputs
`(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)