[bug#76910,v3,4/5] gnu: Add hypr-darkwindow.
Commit Message
* gnu/packages/wm.scm (hypr-darkwindow): New variable.
Change-Id: Ide445c85047e17b5817580bde896a6c303e6a4cd
---
gnu/packages/wm.scm | 47 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)
@@ -610,6 +610,53 @@ (define-public hy3
including node-based window manipulation and optional autotiling.")
(license license:gpl3))))
+(define-public hypr-darkwindow
+ (let ((commit "2d2e7ebac5c52cb23f3cbf06052ceba47a73802d"))
+ (package
+ (name "hypr-darkwindow")
+ (version (git-version "0.48.1" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/micha4w/Hypr-DarkWindow")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0avrc6bcgynvb0j5hw3fh585n971kxrk8bfgwpng6d5m6flav26z"))))
+ (build-system gnu-build-system)
+ (native-inputs (list gcc-14 pkg-config))
+ (inputs (list aquamarine
+ eudev
+ hyprgraphics
+ hyprlang
+ hyprutils
+ libdrm
+ libinput
+ libxkbcommon
+ mesa
+ pango
+ pixman
+ wayland
+ hyprland))
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* _
+ (install-file "out/hypr-darkwindow.so"
+ (string-append #$output "/lib")))))))
+ (home-page "https://github.com/micha4w/Hypr-DarkWindow")
+ (synopsis "Hyprland plugin that provides window color inversion")
+ (description
+ "This plugin adds the dispatchers @code{invertwindow WINDOW}
+and @code{invertactivewindow}, which invert the colors of the indicated
+window.")
+ (license license:expat))))
+
(define-public i3status
(package
(name "i3status")