diff mbox series

[bug#65290,emacs-team,1/2] gnu: emacs-emacsql: Update to 3.1.1-1.29194a6.

Message ID 92438a4c1d278cd808dba2308cf86ef6dd2474d7.1692024757.git.arjan@adriaan.se
State New
Headers show
Series fix emacs-emacsql and related packages | expand

Commit Message

Arjan Adriaanse Aug. 14, 2023, 2:56 p.m. UTC
This commit fixes the check phase when building with Emacs 29.

* gnu/packages/emacs-xyz.scm (emacs-emacsql): Update to 3.1.1-1.29194a6.
[arguments]<#:phases>{remove-sqlite-builtin}: Remove phase.
---
 gnu/packages/emacs-xyz.scm | 12 +++---------
 1 file changed, 3 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1a44926729..6dc98183f8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21900,8 +21900,8 @@  (define-public emacs-finalize
   (license license:unlicense)))
 
 (define-public emacs-emacsql
-  (let ((commit "e1baaf2f874df7f9259a8ecca978e03d3ddae5b5")
-        (revision "0"))
+  (let ((commit "29194a63ede3ee24c7457c2fde03b0f1320ca4b1")
+        (revision "1"))
     (package
       (name "emacs-emacsql")
       (version (git-version "3.1.1" revision commit))
@@ -21913,7 +21913,7 @@  (define-public emacs-emacsql
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0dvqs1jg5zqn0i3r67sn1a40h5rm961q9vxvmqxbgvdhkjvip8fn"))))
+          (base32 "14yj53xxqi3009bdj39k2fqwyc896yp2m7gdkgyv47wlkh1xwzxh"))))
       (build-system emacs-build-system)
       (arguments
        (list
@@ -21929,12 +21929,6 @@  (define-public emacs-emacsql
                     (srfi srfi-26))
         #:phases
         #~(modify-phases %standard-phases
-            (add-before 'install 'remove-sqlite-builtin
-              ;; Current emacs 28.2 doesn't have sqlite feature and compilation
-              ;; of this file fails.  This phase should be removed, when emacs
-              ;; package is updated to 29.
-              (lambda _
-                (delete-file "emacsql-sqlite-builtin.el")))
             (add-before 'install 'patch-elisp-shell-shebangs
               (lambda _
                 (substitute* (find-files "." "\\.el")