diff mbox series

[bug#65976,v4,3/4] gnu: Add ghc-strings.

Message ID 91ec946613afc7f9259354c043b4fd6ced4242ef.1698139370.git.pinoaffe@gmail.com
State New
Headers show
Series [bug#65976,v4,1/4] gnu: Add ghc-twain. | expand

Commit Message

pinoaffe Oct. 24, 2023, 9:24 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-strings): New variable.
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 6d540aee54..4328363a01 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15961,6 +15961,32 @@  (define-public ghc-base64
 (additional support for RFC 7049 standards)")
     (license license:bsd-3)))
 
+(define-public ghc-strings
+  (package
+    (name "ghc-strings")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "strings" version))
+              (sha256
+               (base32
+                "1xz9v3w5s13yhk7iy9dw6i8s2jc6c0b1ci96dwmcq9a1n3l3ng4v"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "strings")))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "0jk1g71yzc5wpkr3vvhnxak61nqvisc5n90ggv6lmz4wqpqzdd0v")))
+    (home-page "https://hub.darcs.net/scravy/strings")
+    (synopsis
+     "Functions for working with strings, including Text and ByteString")
+    (description
+     "This package provides various functions for working with strings, such
+as @code{join}, @code{split}, @code{toUppercase}, et cetera.  The functions in
+this package work with all kinds of strings such as @code{Text},
+@code{ByteString}, @code{S tring}, and their respective lazy counter parts.
+There is also an interface which is agnostic of the underlying string type.")
+    (license license:expat)))
+
 (define-public ghc-ordered-containers
   (package
     (name "ghc-ordered-containers")