diff mbox series

[bug#54065,v2,1/3] gnu: Add poco.

Message ID 91bd55c20b57aa4272e710f139551f9244addeb5.camel@gmail.com
State Accepted
Headers show
Series [bug#54065,v2,1/3] gnu: Add poco. | expand

Commit Message

Liliana Marie Prikler Feb. 19, 2022, 3:03 p.m. UTC
* gnu/packages/cpp.scm (poco): New variable.
---
 gnu/packages/cpp.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Ludovic Courtès April 5, 2022, 2:08 p.m. UTC | #1
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

> * gnu/packages/cpp.scm (poco): New variable.

[...]

> +    (synopsis "Portable C++ components")
> +    (description "A collection of libraries intended to be useful for building
> +network-based applications.")

Please make it a full sentence (info "(guix) Synopses and Descriptions").

> * gnu/packages/telephony.scm (find-python-interpreter-cmake-modules):
> New variable.
> (mumble): Update to 1.4.230.
> [source]: Adjust uri and snippet accordingly.
> [arguments]: Change to a list of G-expressions.
> <#:configure-flags>: New argument.
> <#:phases>: Drop ‘configure’ (moved to configure-flags).
> Add ‘unpack-submodules’, ‘fix-settings-crash’ and ‘hardcode-pulseaudio’.
> [inputs]: Add glib and poco.

[...]

> * gnu/packages/telephony.scm (mumble)[#:tests?]: Drop argument.
> [#:configure-flags]: Add “-Dtests=on”.

I believe Maxime’s comments were addressed and the rest LGTM, thanks!

Ludo’.
Liliana Marie Prikler April 5, 2022, 7:09 p.m. UTC | #2
Am Dienstag, dem 05.04.2022 um 16:08 +0200 schrieb Ludovic Courtès:
> Hi,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
> 
> > * gnu/packages/cpp.scm (poco): New variable.
> 
> [...]
> 
> > +    (synopsis "Portable C++ components")
> > +    (description "A collection of libraries intended to be useful
> > for building
> > +network-based applications.")
> 
> Please make it a full sentence (info "(guix) Synopses and
> Descriptions").
Ahh, sorry.  I've applied a fix locally and will push it once checks
are finished.

> I believe Maxime’s comments were addressed and the rest LGTM, thanks!
Sorry, I already pushed the mumble update including the faulty
description for poco.  Will fix asap.
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 1227e705c3..7968db2acc 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1072,6 +1072,39 @@  (define-public folly
     (supported-systems '("aarch64-linux" "x86_64-linux"))
     (license license:asl2.0)))
 
+(define-public poco
+  (package
+    (name "poco")
+    (version "1.11.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pocoproject/poco")
+                    (commit (string-append "poco-" version "-release"))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0qkf8vb4qwds6idk9fkw6wjvcdk5k8h77x3gv47l0i4jfl5hwn8b"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:configure-flags #~(list "-DENABLE_TESTS=ON")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'disable-problematic-tests
+            (lambda _
+              (substitute* (list "Foundation/CMakeLists.txt" ; XXX: fails.
+                                 ;; Require network access
+                                 "Net/CMakeLists.txt"
+                                 "MongoDB/CMakeLists.txt"
+                                 "Redis/CMakeLists.txt")
+                (("ENABLE_TESTS") "FALSE")))))))
+    (home-page "https://pocoproject.org/")
+    (synopsis "Portable C++ components")
+    (description "A collection of libraries intended to be useful for building
+network-based applications.")
+    (license license:boost1.0)))
+
 (define-public aws-crt-cpp
   (let* ((commit "b6d311d76b504bf8ace5134d3fca0e672c36c9c3")
          (revision "1"))