[bug#76854,4/7] gnu: Add rust-nucleo-0.5.

Message ID 91bcf3ae1ff751af6ee6b755b4c4884d9190f776.1741388878.git.me@alexbos.co
State New
Headers
Series gnu: Add tmux-sessionizer plugin. |

Commit Message

Alex Bosco March 8, 2025, 1:16 p.m. UTC
  Change-Id: I383c8c5ee7ca72f762a5bde9af9691fc5032835b
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++----
 1 file changed, 21 insertions(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6e5d63f534..364957b199 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -47922,20 +47922,20 @@  (define-public rust-ntex-bytes-0.1
     (description "Types and traits for working with bytes (bytes crate fork)")
     (license license:expat)))
 
-(define-public rust-nucleo-0.2
+(define-public rust-nucleo-0.5
   (package
     (name "rust-nucleo")
-    (version "0.2.1")
+    (version "0.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "nucleo" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1wzx32bz4n68dcd3yw57195sz49hdhv9b75jikr5qiyfpks32lxf"))))
+        (base32 "1m1rq0cp02hk31z7jsn2inqcpy9a1j8gfvxcqm32c74jji6ayqjj"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs (("rust-nucleo-matcher" ,rust-nucleo-matcher-0.2)
+     `(#:cargo-inputs (("rust-nucleo-matcher" ,rust-nucleo-matcher-0.3)
                        ("rust-parking-lot" ,rust-parking-lot-0.12)
                        ("rust-rayon" ,rust-rayon-1))))
     (home-page "https://github.com/helix-editor/nucleo")
@@ -47944,6 +47944,23 @@  (define-public rust-nucleo-0.2
      "This package provides plug and play high performance fuzzy matcher.")
     (license license:mpl2.0)))
 
+(define-public rust-nucleo-0.2
+  (package
+    (inherit rust-nucleo-0.5)
+    (name "rust-nucleo")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "nucleo" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1wzx32bz4n68dcd3yw57195sz49hdhv9b75jikr5qiyfpks32lxf"))))
+    (arguments
+     `(#:cargo-inputs (("rust-nucleo-matcher" ,rust-nucleo-matcher-0.2)
+                       ("rust-parking-lot" ,rust-parking-lot-0.12)
+                       ("rust-rayon" ,rust-rayon-1))))))
+
 (define-public rust-nucleo-matcher-0.3
   (package
     (name "rust-nucleo-matcher")