diff mbox series

[bug#43310] gnu: Add lsp-dsp-lib.

Message ID 9160c83dd3e513eb0f73b6a8b22ee78323fd2555.camel@zrythm.org
State Accepted
Headers show
Series [bug#43310] gnu: Add lsp-dsp-lib. | expand

Commit Message

Alexandros Theodotou Sept. 10, 2020, 3:19 p.m. UTC
Hi,

This patch adds lsp-dsp-lib.

Thanks,
Alex

Comments

Efraim Flashner Sept. 14, 2020, 2:02 p.m. UTC | #1
On Thu, Sep 10, 2020 at 04:19:39PM +0100, Alexandros Theodotou wrote:
> Hi,
> 
> This patch adds lsp-dsp-lib.
> 
> Thanks,
> Alex

It looks like everything in the modules directory is vendored. Can we
build it separately and link it in? Also, I saw that there were a few
test directories. Are there tests to be built?

> From 8708b830c3be565c6ada9cb1b6042acc5174f86f Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Thu, 10 Sep 2020 16:17:22 +0100
> Subject: [PATCH] gnu: Add lsp-dsp-lib.
> 
> * gnu/packages/audio.scm (lsp-dsp-lib): New variable.
> ---
>  gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
> 
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index eecbf5260b..1d49482ee3 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -4790,6 +4790,37 @@ edited, converted, compressed and saved.")
>         ,@(package-inputs ztoolkit)))
>      (synopsis "ZToolkit with SVG support")))
>  
> +(define-public lsp-dsp-lib
> +  (package
> +    (name "lsp-dsp-lib")
> +    (version "0.5.8")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append "https://github.com/sadko4u/lsp-dsp-lib/"
> +                            "releases/download/lsp-dsp-lib-" version
> +                            "/lsp-dsp-lib-" version "-src.tar.gz"))
> +        (sha256
> +         (base32
> +          "07w3d2i0z0xmvi1ngcgs7lc5a0da8jvf7rv4dnjk01md43b7fkh1"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f ; no tests
> +       #:make-flags
> +       (list "CC=gcc")

This can be cc-for-target
         (list (string-append "CC=" ,(cc-for-target)))

> +       #:phases
> +       (modify-phases %standard-phases
> +         (replace 'configure
> +           (lambda _
> +             (invoke "make" "config" (string-append "PREFIX=" (assoc-ref %outputs "out")))
> +             #t)))))

We'd rather not use %outputs if possible, but to add it to the lambda.
Also invoke already returns #t

           (lambda* (#:key outputs #:allow-other-keys)
             (invoke "make" "config"
                     (string-append "PREFIX=" (assoc-ref outputs "out"))))))))

> +    (home-page "https://github.com/sadko4u/lsp-dsp-lib")
> +    (synopsis "Digital signal processing library")
> +    (description "The LSP DSP library provides a set of functions that perform
> +SIMD-optimized computing on several hardware architectures.  All functions
> +currently operate on IEEE-754 single-precision floating-point numbers.")
> +    (license license:lgpl3+)))
> +
>  (define-public codec2
>    (package
>      (name "codec2")
> -- 
> 2.27.0
>
diff mbox series

Patch

From 8708b830c3be565c6ada9cb1b6042acc5174f86f Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Thu, 10 Sep 2020 16:17:22 +0100
Subject: [PATCH] gnu: Add lsp-dsp-lib.

* gnu/packages/audio.scm (lsp-dsp-lib): New variable.
---
 gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index eecbf5260b..1d49482ee3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4790,6 +4790,37 @@  edited, converted, compressed and saved.")
        ,@(package-inputs ztoolkit)))
     (synopsis "ZToolkit with SVG support")))
 
+(define-public lsp-dsp-lib
+  (package
+    (name "lsp-dsp-lib")
+    (version "0.5.8")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://github.com/sadko4u/lsp-dsp-lib/"
+                            "releases/download/lsp-dsp-lib-" version
+                            "/lsp-dsp-lib-" version "-src.tar.gz"))
+        (sha256
+         (base32
+          "07w3d2i0z0xmvi1ngcgs7lc5a0da8jvf7rv4dnjk01md43b7fkh1"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:make-flags
+       (list "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (invoke "make" "config" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+             #t)))))
+    (home-page "https://github.com/sadko4u/lsp-dsp-lib")
+    (synopsis "Digital signal processing library")
+    (description "The LSP DSP library provides a set of functions that perform
+SIMD-optimized computing on several hardware architectures.  All functions
+currently operate on IEEE-754 single-precision floating-point numbers.")
+    (license license:lgpl3+)))
+
 (define-public codec2
   (package
     (name "codec2")
-- 
2.27.0