diff mbox series

[bug#62389,v2,6/6] gnu: synapse: Update to 1.67.0.

Message ID 916053d6d7b02004c2447edf99210a2b5dc63b6d.1686158921.git.me@mianmoreno.com
State New
Headers show
Series [bug#62389,v2,1/6] gnu: Add python-matrix-common. | expand

Commit Message

Miguel Ángel Moreno June 7, 2023, 5:33 p.m. UTC
* gnu/packages/matrix.scm (synapse): Update to 1.67.0.
[propagated-inputs]: Add Python dependencies.
[arguments]: Disable tests.
---
 gnu/packages/matrix.scm | 22 +++++++++++++++++-----
 1 file changed, 17 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index f356674ed9..f67591f934 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -33,6 +33,7 @@  (define-module (gnu packages matrix)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages xml)
   #:use-module (guix build-system python)
   #:use-module (guix download)
@@ -93,14 +94,18 @@  (define-public python-matrix-synapse-ldap3
 (define-public synapse
   (package
     (name "synapse")
-    (version "1.29.0")
+    (version "1.67.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "matrix-synapse" version))
               (sha256
                (base32
-                "0if2yhpz8psg0661401mvxznldbfhk2j9rhbs25jdaqm9jsv6907"))))
+                "05mljp6jjz7ylmmjvlvxm3w9h3ynrjq5b3b3zssmr48lbjxrb8pk"))))
     (build-system python-build-system)
+    (arguments
+     (list
+      ;; Tests require network access
+      #:tests? #f))
     ;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
     (propagated-inputs
      (list python-simplejson ; not attested but required
@@ -133,11 +138,18 @@  (define-public synapse
            python-jinja2
            python-bleach
            python-typing-extensions
-           ;; conditional requirements (synapse/python_dependencies.py)
-           ;;("python-hiredis" ,python-hiredis)
+           python-matrix-common
+           python-pyperf
+           python-redis
+           python-cryptography
+           python-ijson
+           python-pydantic
+           ;; conditional requirements (pyproject.toml)
            python-matrix-synapse-ldap3
            python-psycopg2
            python-jinja2
+           python-txredisapi
+           python-hiredis
            python-txacme
            python-pysaml2
            python-lxml
@@ -146,7 +158,7 @@  (define-public synapse
            ;; all are monitoring aids and not essential.
            python-pyjwt))
     (native-inputs
-     (list python-mock python-parameterized))
+     (list python-mock python-parameterized openssl))
     (home-page "https://github.com/matrix-org/synapse")
     (synopsis "Matrix reference homeserver")
     (description "Synapse is a reference \"homeserver\" implementation of