@@ -33,6 +33,7 @@ (define-module (gnu packages matrix)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages xml)
#:use-module (guix build-system python)
#:use-module (guix download)
@@ -93,14 +94,18 @@ (define-public python-matrix-synapse-ldap3
(define-public synapse
(package
(name "synapse")
- (version "1.29.0")
+ (version "1.67.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "matrix-synapse" version))
(sha256
(base32
- "0if2yhpz8psg0661401mvxznldbfhk2j9rhbs25jdaqm9jsv6907"))))
+ "05mljp6jjz7ylmmjvlvxm3w9h3ynrjq5b3b3zssmr48lbjxrb8pk"))))
(build-system python-build-system)
+ (arguments
+ (list
+ ;; Tests require network access
+ #:tests? #f))
;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
(propagated-inputs
(list python-simplejson ; not attested but required
@@ -133,11 +138,18 @@ (define-public synapse
python-jinja2
python-bleach
python-typing-extensions
- ;; conditional requirements (synapse/python_dependencies.py)
- ;;("python-hiredis" ,python-hiredis)
+ python-matrix-common
+ python-pyperf
+ python-redis
+ python-cryptography
+ python-ijson
+ python-pydantic
+ ;; conditional requirements (pyproject.toml)
python-matrix-synapse-ldap3
python-psycopg2
python-jinja2
+ python-txredisapi
+ python-hiredis
python-txacme
python-pysaml2
python-lxml
@@ -146,7 +158,7 @@ (define-public synapse
;; all are monitoring aids and not essential.
python-pyjwt))
(native-inputs
- (list python-mock python-parameterized))
+ (list python-mock python-parameterized openssl))
(home-page "https://github.com/matrix-org/synapse")
(synopsis "Matrix reference homeserver")
(description "Synapse is a reference \"homeserver\" implementation of