[bug#77371,06/12] gnu: Add python-histoprint.

Message ID 915ecba3500c8ea84685d0b0a950d101b3887bd2.1743288280.git.monego@posteo.net
State New
Headers
Series Add packages from the scikit-hep project |

Commit Message

Vinicius Monego March 29, 2025, 11 p.m. UTC
  * gnu/packages/python-science.scm (python-histoprint): New variable.

Change-Id: I1ace11116c39e2c803afd10849c107c3f232273e
---
 gnu/packages/python-science.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index ced52c4b51..24e1fca1d3 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1029,6 +1029,30 @@  (define-public python-uhi
 docs dependency in support of other libraries.")
     (license license:bsd-3)))
 
+(define-public python-histoprint
+  (package
+    (name "python-histoprint")
+    (version "2.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "histoprint" version))
+       (sha256
+        (base32 "07d2lk64gwhjvw4wccvwks3j4ig7g99q627jjxz4ans5a29p5pz1"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-click python-numpy python-uhi))
+    (native-inputs (list python-awkward
+                         python-boost-histogram
+                         python-hatch-vcs
+                         python-hatchling
+                         python-pytest
+                         python-rich))
+    (home-page "https://github.com/scikit-hep/histoprint")
+    (synopsis "Pretty print histograms to the console")
+    (description "Histoprint uses a mix of terminal color codes and Unicode
+trickery (i.e. combining characters) to plot overlaying histograms.")
+    (license license:bsd-3)))
+
 (define-public python-tdda
   (package
     (name "python-tdda")