diff mbox series

[bug#72144,2/2] gnu: Add python-lcapy.

Message ID 911c8e3ccd2e984573fd2d2b2143007684336f41.1721163251.git.monego@posteo.net
State New
Headers show
Series Add python-lcapy | expand

Commit Message

Vinicius Monego July 16, 2024, 11:38 p.m. UTC
* gnu/packages/engineering.scm (python-lcapy): New variable.

Change-Id: Ieca7f9e717dd1cd59ebe124bd51937680f8c9eb5
---
 gnu/packages/engineering.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cc9020c6fd..efd437713d 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2664,6 +2664,42 @@  (define-public python-scikit-rf
 Microwave engineering.")
     (license license:bsd-3)))
 
+(define-public python-lcapy
+  (package
+    (name "python-lcapy")
+    (version "1.23")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "lcapy" version))
+       (sha256
+        (base32 "13swd2nd2s20hixy4as924sr223flcvcy9zw3qlzsrcvhppzb84n"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; This test fails by FileNotFoundError (a schematic file), possibly
+      ;; because it's not included in PyPI.
+      #:test-flags #~(list "-k" "not test_circuitgraph")))
+    (propagated-inputs (list python-ipython
+                             python-matplotlib
+                             python-networkx
+                             python-numpy
+                             python-property-cached
+                             python-scipy
+                             python-setuptools
+                             python-sympy
+                             python-wheel))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/mph-/lcapy")
+    (synopsis "Symbolic linear circuit analysis")
+    (description "Lcapy is a Python package for linear circuit analysis.  It
+uses SymPy for symbolic mathematics.
+
+Lcapy can symbolically analyse circuits described with netlists or by
+series/parallel combinations of components.  It can also manipulate
+ontinuous-time and discret-time expressions.")
+    (license license:lgpl2.1+)))
+
 (define-public openscad
   (package
     (name "openscad")