diff mbox series

[bug#66586,v2] gnu: lvm2: Remove systemd rule.

Message ID 9102296a5c1faade8528ec115eee7ebb17ce9a5f.1698165907.git.zimon.toutoune@gmail.com
State New
Headers show
Series [bug#66586,v2] gnu: lvm2: Remove systemd rule. | expand

Commit Message

Simon Tournier Oct. 24, 2023, 4:47 p.m. UTC
From: Yann Dupont <Yann.Dupont@univ-nantes.fr>

Fixes <https://issues.guix.gnu.org/65177>.
Reported by Adrien 'neox' Bourmault <neox@gnu.org>.

* gnu/packages/patches/lvm2-no-systemd.patch: New file.
* gnu/packages/linux.scm (lvm2)[source]: Apply patch.
* gnu/local.mk: Register new patch.
---
 gnu/local.mk                               |  1 +
 gnu/packages/linux.scm                     |  1 +
 gnu/packages/patches/lvm2-no-systemd.patch | 20 ++++++++++++++++++++
 3 files changed, 22 insertions(+)
 create mode 100644 gnu/packages/patches/lvm2-no-systemd.patch


base-commit: f3714b3d5f51aced4b31447c42d5e89c75e3079f

Comments

Ludovic Courtès Oct. 29, 2023, 11:22 p.m. UTC | #1
Simon Tournier <zimon.toutoune@gmail.com> skribis:

> From: Yann Dupont <Yann.Dupont@univ-nantes.fr>
>
> Fixes <https://issues.guix.gnu.org/65177>.
> Reported by Adrien 'neox' Bourmault <neox@gnu.org>.
>
> * gnu/packages/patches/lvm2-no-systemd.patch: New file.
> * gnu/packages/linux.scm (lvm2)[source]: Apply patch.
> * gnu/local.mk: Register new patch.

LGTM, thanks!
Simon Tournier Oct. 31, 2023, 8:58 a.m. UTC | #2
Hi,

On lun., 30 oct. 2023 at 00:22, Ludovic Courtès <ludo@gnu.org> wrote:
> Simon Tournier <zimon.toutoune@gmail.com> skribis:
>
>> From: Yann Dupont <Yann.Dupont@univ-nantes.fr>
>>
>> Fixes <https://issues.guix.gnu.org/65177>.
>> Reported by Adrien 'neox' Bourmault <neox@gnu.org>.
>>
>> * gnu/packages/patches/lvm2-no-systemd.patch: New file.
>> * gnu/packages/linux.scm (lvm2)[source]: Apply patch.
>> * gnu/local.mk: Register new patch.
>
> LGTM, thanks!

Pushed as c0895371c5759c7d9edb330774e90f192cc4cf2c.

Cheers,
simon
Josselin Poiret Oct. 31, 2023, 8:07 p.m. UTC | #3
Hi everyone,

The given .patch file is malformed: there are no closing double quotes
for each of the strings.  Additionally, I don't believe that the
reference to systemd has been truly removed with this, as it's
referenced in the second line of the patch.

I get errors immediately in my dmesg when booting with this patch.  Has
this been tested?  I believe this will affect users relying on LVM
volumes.

Best,
Simon Tournier Oct. 31, 2023, 9:28 p.m. UTC | #4
Hi,

On Tue, 31 Oct 2023 at 21:07, Josselin Poiret via Guix-patches via <guix-patches@gnu.org> wrote:

> I get errors immediately in my dmesg when booting with this patch.

Reverted 3991d9e4d9867ec499283bfc71b34d7bfebe49b3.  Oops, sorry for the
annoyance.  I screwed up!

Could you propose a fix for <https://issues.guix.gnu.org/65177>?

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 43145caf80..4c8800b274 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1627,6 +1627,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/mcrypt-CVE-2012-4527.patch			\
   %D%/packages/patches/libmemcached-build-with-gcc7.patch	\
   %D%/packages/patches/libmhash-hmac-fix-uaf.patch		\
+  %D%/packages/patches/lvm2-no-systemd.patch    		\
   %D%/packages/patches/maturin-no-cross-compile.patch		\
   %D%/packages/patches/mecab-variable-param.patch		\
   %D%/packages/patches/memtest86+-build-reproducibly.patch	\
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f02577d2d5..c618651553 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4494,6 +4494,7 @@  (define-public lvm2
               (sha256
                (base32
                 "0z6w6bknhwh1n3qfkb5ij6x57q3wjf28lq3l8kh7rkhsplinjnjc"))
+              (patches (search-patches "lvm2-no-systemd.patch"))
               (modules '((guix build utils)))
               (snippet
                '(begin
diff --git a/gnu/packages/patches/lvm2-no-systemd.patch b/gnu/packages/patches/lvm2-no-systemd.patch
new file mode 100644
index 0000000000..440559b96d
--- /dev/null
+++ b/gnu/packages/patches/lvm2-no-systemd.patch
@@ -0,0 +1,20 @@ 
+Fixes <https://issues.guix.gnu.org/65177>.
+
+Run 'vgchange' directly instead of attempting to run it via 'systemd-run' as
+the udev rules included in lvm2 >= 2.03.14 do.
+
+diff --git a/udev/69-dm-lvm.rules.in b/udev/69-dm-lvm.rules.in
+index ff15681..f9e5b70 100644
+--- a/udev/69-dm-lvm.rules.in
++++ b/udev/69-dm-lvm.rules.in
+@@ -75,8 +75,8 @@ LABEL="lvm_scan"
+ # TODO: adjust the output of vgchange -aay so that
+ # it's better suited to appearing in the journal.
+ 
+-IMPORT{program}="(LVM_EXEC)/lvm pvscan --cache --listvg --checkcomplete --vgonline --autoactivation event --udevoutput --journal=output $env{DEVNAME}"
+-ENV{LVM_VG_NAME_COMPLETE}=="?*", RUN+="(SYSTEMDRUN) --no-block --property DefaultDependencies=no --unit lvm-activate-$env{LVM_VG_NAME_COMPLETE} (LVM_EXEC)/lvm vgchange -aay --autoactivation event $env{LVM_VG_NAME_COMPLETE}"
++IMPORT{program}="(LVM_EXEC)/lvm pvscan --cache --listvg
++ENV{LVM_VG_NAME_COMPLETE}=="?*", RUN+="(SYSTEMDRUN) --no-block lvm-activate-$env{LVM_VG_NAME_COMPLETE} (LVM_EXEC)/lvm vgchange -aay
+ GOTO="lvm_end"
+ 
+ LABEL="lvm_end"