diff mbox series

[bug#58074,staging,v3,1/2] gnu: cyrus-sasl: Set SASL_PATH to find plugins

Message ID 90f054c85b00bb046fb29af990e24eddb472134c.1691097881.git.mail@reilysiegel.com
State New
Headers show
Series [bug#58074,staging,v3,1/2] gnu: cyrus-sasl: Set SASL_PATH to find plugins | expand

Commit Message

Reily Siegel Dec. 23, 2022, 7:27 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[native-search-paths]: Add
"lib/sasl2" to SASL_PATH
---

I added the patches from this issue to a personal Guix checkout, and was
unable to build cyrus-sasl-xoauth2 due to autogen.sh being an executable
file without a shebang. This updated patch sets the permission bits to
o400, so that the bootstrap phase passes autogen.sh to /bin/sh, rather
than attempt to execute it directly.

 gnu/packages/cyrus-sasl.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)


base-commit: 4ded034a57ffacdd6c7afa73bb58893afd614644
prerequisite-patch-id: 081e3072b6b3a070fffd62da42f3e622317684bf

Comments

Samuel Matthiesen Feb. 12, 2024, 6:48 p.m. UTC | #1
Hi,

Reily Siegel (2022-12-23 14:27 -0500):
> From: Morgan Smith <Morgan.J.Smith@outlook.com> 
> 
> * gnu/packages/cyrus-sasl.scm (cyrus-sasl)[native-search-paths]: 
> Add "lib/sasl2" to SASL_PATH --- 
> 
> I added the patches from this issue to a personal Guix checkout, 
> and was unable to build cyrus-sasl-xoauth2 due to autogen.sh 
> being an executable file without a shebang. This updated patch 
> sets the permission bits to o400, so that the bootstrap phase 
> passes autogen.sh to /bin/sh, rather than attempt to execute it 
> directly.

I have tested the patch from Reily and it works for me. Solved my 
issue of not having cyrus-sasl-xoauth2 packaged in Guix yet. Is 
this ready for merging?


Samuel
diff mbox series

Patch

diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 70d579c127..8254e04993 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -63,9 +63,13 @@  (define-public cyrus-sasl
       ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
       ;; fail with EEXIST when building things in parallel.
       #:parallel-build? #f))
-    (synopsis "Simple Authentication Security Layer implementation")
-    (description
-     "SASL (Simple Authentication Security Layer) is an Internet
+   (native-search-paths
+    (list (search-path-specification
+           (variable "SASL_PATH")
+           (files (list "lib/sasl2")))))
+   (synopsis "Simple Authentication Security Layer implementation")
+   (description
+    "SASL (Simple Authentication Security Layer) is an Internet
 standards-track method for remote computers to authenticate.  The Cyrus SASL
 library makes supporting various SASL mechanisms easy for both client and
 server writers.")