diff mbox series

[bug#71026,17/36] gnu: Add rust-hyper-rustls-0.26.0

Message ID 90e795b401cb2debedb67c3e7e843a7ad9c6110e.1716014757.git.voroskoi@gmail.com
State New
Headers show
Series [bug#71026,01/36] gnu: rust-anyhow: Update to 1.0.82. | expand

Commit Message

VÖRÖSKŐI András May 18, 2024, 6:45 a.m. UTC
* gnu/packages/crates-web.scm (rust-hyper-rustls-0.26): New variable.

Change-Id: I7684bed7b5df8c0f424d0cfe4b6ea7fe8434e7f6
---
 gnu/packages/crates-web.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index d02be679a9..6f249e8f50 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -3746,6 +3746,43 @@  (define-public rust-hyper-proxy-0.9
     (description "Proxy connector for the Hyper HTTP library.")
     (license license:expat)))
 
+(define-public rust-hyper-rustls-0.26
+  (package
+    (name "rust-hyper-rustls")
+    (version "0.26.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hyper-rustls" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0b4m1jvs147hxi8677n2dxxib663s7c31xmfni7b5qkanihsggm0"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f              ; Not all files included.
+       #:cargo-inputs (("rust-futures-util" ,rust-futures-util-0.3)
+                       ("rust-http" ,rust-http-1)
+                       ("rust-hyper" ,rust-hyper-1)
+                       ("rust-hyper-util" ,rust-hyper-util-0.1)
+                       ("rust-log" ,rust-log-0.4)
+                       ("rust-rustls" ,rust-rustls-0.22)
+                       ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.7)
+                       ("rust-rustls-pki-types" ,rust-rustls-pki-types-1)
+                       ("rust-tokio" ,rust-tokio-1)
+                       ("rust-tokio-rustls" ,rust-tokio-rustls-0.25)
+                       ("rust-tower-service" ,rust-tower-service-0.3)
+                       ("rust-webpki-roots" ,rust-webpki-roots-0.26))
+       #:cargo-development-inputs (("rust-http-body-util" ,rust-http-body-util-0.1)
+                                   ("rust-hyper-util" ,rust-hyper-util-0.1)
+                                   ("rust-rustls" ,rust-rustls-0.22)
+                                   ("rust-rustls-pemfile" ,rust-rustls-pemfile-2)
+                                   ("rust-tokio" ,rust-tokio-1))))
+    (home-page "https://github.com/rustls/hyper-rustls")
+    (synopsis "Rustls+Hyper integration for pure Rust HTTPS")
+    (description
+     "This package provides Rustls+Hyper integration for pure Rust HTTPS.")
+    (license (list license:asl2.0 license:isc license:expat))))
+
 (define-public rust-hyper-rustls-0.24
   (package
     (name "rust-hyper-rustls")