diff mbox series

[bug#72572] gnu: Add elinks.

Message ID 90ca0a57-30bf-2b10-5e27-6b6d3e709cbe@disroot.org
State New
Headers show
Series [bug#72572] gnu: Add elinks. | expand

Commit Message

Adam Faiz Aug. 11, 2024, 9:29 a.m. UTC
From e5f84076855745ba103053933beafbd75a4c68d2 Mon Sep 17 00:00:00 2001
Message-ID: <e5f84076855745ba103053933beafbd75a4c68d2.1723368423.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 11 Aug 2024 17:26:37 +0800
Subject: [PATCH] gnu: Add elinks.

* gnu/packages/web-browsers.scm (elinks): New variable.
---
 gnu/packages/web-browsers.scm | 57 +++++++++++++++++++++++++++++++++++
 1 file changed, 57 insertions(+)


base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8

Comments

Nicolas Graves Aug. 15, 2024, 4:57 p.m. UTC | #1
user guix
usertag 72572 + reviewed-looks-good
thanks

Guix QA review form submission:
Hi Adam, 
Thanks for this package, it builds deterministically and no lints. I just have a doubt over the license given both the description that it&apos;s GPVv2 and not later (so license:gpl2 would seem more appropriate instead of license:gpl2+). Additionnally, other licenses are evocated in this file : 
https://github.com/rkd77/elinks?tab=License-1-ov-file#readme
although I&apos;m not sure we should include all these licenses.

Items marked as checked: Lint warnings, Package builds, Commit messages, New package tests, New package synopsis and descriptions
Z572 Aug. 17, 2024, 3:28 a.m. UTC | #2
Adam Faiz via Guix-patches via <guix-patches@gnu.org> writes:

> From e5f84076855745ba103053933beafbd75a4c68d2 Mon Sep 17 00:00:00 2001
> Message-ID: <e5f84076855745ba103053933beafbd75a4c68d2.1723368423.git.adam.faiz@disroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Sun, 11 Aug 2024 17:26:37 +0800
> Subject: [PATCH] gnu: Add elinks.
>
> * gnu/packages/web-browsers.scm (elinks): New variable.
> ---
>  gnu/packages/web-browsers.scm | 57 +++++++++++++++++++++++++++++++++++
>  1 file changed, 57 insertions(+)
>
> diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
> index 4a2b28916d..adb9444dac 100644
> --- a/gnu/packages/web-browsers.scm
> +++ b/gnu/packages/web-browsers.scm
> @@ -97,6 +97,7 @@ (define-module (gnu packages web-browsers)
>    #:use-module (gnu packages python-xyz)
>    #:use-module (gnu packages qt)
>    #:use-module (gnu packages readline)
> +  #:use-module (gnu packages regex)
>    #:use-module (gnu packages sdl)
>    #:use-module (gnu packages sqlite)
>    #:use-module (gnu packages suckless)
> @@ -105,6 +106,7 @@ (define-module (gnu packages web-browsers)
>    #:use-module (gnu packages tls)
>    #:use-module (gnu packages web)
>    #:use-module (gnu packages webkit)
> +  #:use-module (gnu packages xml)
>    #:use-module (gnu packages xorg))
>  
>  (define-public midori
> @@ -218,6 +220,61 @@ (define-public links
>      ;; linking of the program with openssl.
>      (license license:gpl1+)))
>  
> +(define-public elinks
> +  (package
> +    (name "elinks")
> +    (version "0.17.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/rkd77/elinks")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "0ij738y1ig2cdfdim85al9iyqz6cwrfac0zg0mqrqj9af0q25r95"))))
> +    (build-system gnu-build-system)

can you switch to meson-build-system? I think it's better this way.

> +    (arguments
> +     (list
> +      #:configure-flags
> +      #~(list "--enable-finger"
> +              "--enable-html-highlight"
> +              "--enable-gopher"
> +              "--enable-gemini"
> +              "--enable-cgi"
> +              "--enable-bittorrent"
> +              "--enable-nntp"
> +              "--enable-256-colors"
> +              "--enable-true-color"
> +              "--with-brotli"
> +              "--with-lzma"
> +              "--with-libev")))
> +    (native-inputs
> +     (list autoconf
> +           automake
> +           gnu-gettext
> +           pkg-config))
> +    (inputs
> +     (list brotli
> +           bzip2
> +           expat
> +           gnutls
> +           gpm
> +           libev
> +           libgcrypt
> +           libidn
> +           lua
> +           tre
> +           xz
> +           zlib))
> +    (synopsis "Advanced text mode web browser")
> +    (description "ELinks is a feature-rich program for browsing the web
> +in text mode.  It can render both frames and tables, is highly customisable
> +and can be extended via Lua scripts.  It is like an enhanced Lynx and Links.")
> +    (home-page "http://elinks.cz/")
> +    (license license:gpl2+)))
> +
>  (define-public luakit
>    (package
>      (name "luakit")
>
> base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 4a2b28916d..adb9444dac 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -97,6 +97,7 @@  (define-module (gnu packages web-browsers)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages regex)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages suckless)
@@ -105,6 +106,7 @@  (define-module (gnu packages web-browsers)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages webkit)
+  #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
 (define-public midori
@@ -218,6 +220,61 @@  (define-public links
     ;; linking of the program with openssl.
     (license license:gpl1+)))
 
+(define-public elinks
+  (package
+    (name "elinks")
+    (version "0.17.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rkd77/elinks")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ij738y1ig2cdfdim85al9iyqz6cwrfac0zg0mqrqj9af0q25r95"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list "--enable-finger"
+              "--enable-html-highlight"
+              "--enable-gopher"
+              "--enable-gemini"
+              "--enable-cgi"
+              "--enable-bittorrent"
+              "--enable-nntp"
+              "--enable-256-colors"
+              "--enable-true-color"
+              "--with-brotli"
+              "--with-lzma"
+              "--with-libev")))
+    (native-inputs
+     (list autoconf
+           automake
+           gnu-gettext
+           pkg-config))
+    (inputs
+     (list brotli
+           bzip2
+           expat
+           gnutls
+           gpm
+           libev
+           libgcrypt
+           libidn
+           lua
+           tre
+           xz
+           zlib))
+    (synopsis "Advanced text mode web browser")
+    (description "ELinks is a feature-rich program for browsing the web
+in text mode.  It can render both frames and tables, is highly customisable
+and can be extended via Lua scripts.  It is like an enhanced Lynx and Links.")
+    (home-page "http://elinks.cz/")
+    (license license:gpl2+)))
+
 (define-public luakit
   (package
     (name "luakit")