diff mbox series

[bug#68149] gnu: Add lazygit.

Message ID 90a350fa48d10df25ac383687417a15c75722dba.1703942665.git.abr@cock.li
State New
Headers show
Series [bug#68149] gnu: Add lazygit. | expand

Commit Message

abr Dec. 30, 2023, 1:25 p.m. UTC
* gnu/packages/version-control.scm (lazygit): New variable

Change-Id: I2d986f7519b27a389b74d9c87c31ce3f2d58b860
---
 gnu/packages/version-control.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: f76ca2b0e894c244d5011a32b30dee8fd874e322

Comments

Sharlatan Hellseher Jan. 12, 2024, 10:40 p.m. UTC | #1
Hi,

LazyGit has quite a massive list of vendored packages in:

https://github.com/jesseduffield/lazygit/tree/master/vendor

I've tried to pack it a year ago and nearly archived it :-)

wip-golang ref:
https://git.sr.ht/~hellseher/ffab

Mirror
https://github.com/Hellseher/guix-ffab/blob/main/ffab/packages/version-control.scm#L103

How hard would it be to review/prepare all missing packages?

Thanks,
Oleg
-- 
VCS: https://github.incerto.xyz/; https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 013504875b..050e4220a1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3949,3 +3949,26 @@  (define-public commit-patch
 comes as a command line app and also an Emacs interface.")
     (home-page "https://porkrind.org/commit-patch/")
     (license license:gpl2+)))
+
+(define-public lazygit
+  (package
+    (name "lazygit")
+    (version "0.40.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jesseduffield/lazygit")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "049gdbhsaqdpj4bn0k4dbzvwaig40p5vhmnqvj09as3f0wl5cgn6"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/jesseduffield/lazygit"
+       #:go ,go-1.20))
+    (synopsis "Simple terminal UI for git commands")
+    (description
+     "Lazygit is an interactive terminal user interface (TUI) for git.")
+    (home-page "https://github.com/jesseduffield/lazygit")
+    (license license:expat)))
+