diff mbox series

[bug#59188,v7,15/20] gnu: node-openzwave-shared: Fix compilation for new versions of node

Message ID 90996e0ab7b395edc0e223a32a1394ea2d4311f4.1681742871.git.jlicht@fsfe.org
State New
Headers show
Series Updating node-lts to 18.X | expand

Commit Message

Jelle Licht April 17, 2023, 2:51 p.m. UTC
From: Jelle Licht <jlicht@fsfe.org>

* gnu/packages/zwave.scm (node-openzwave-shared)[arguments]<#:phases>: Add
patch-compiler phase to allow compilation with node versions 16 and up.
---

(no changes since v1)

 gnu/packages/zwave.scm | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/zwave.scm b/gnu/packages/zwave.scm
index 3e99bd7687..a30199ec02 100644
--- a/gnu/packages/zwave.scm
+++ b/gnu/packages/zwave.scm
@@ -112,6 +112,11 @@  (define-public node-openzwave-shared
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-before 'build 'patch-compiler
+           (lambda _
+             (substitute* "binding.gyp"
+               (("std=c\\+\\+11")
+                "std=c++17"))))
          (replace 'build
            ;; For some reason, `npm install` doesn't build
            ;; the addon automatically, so we do it explicitly here.