diff mbox series

[bug#70087,2/3] gnu: chuffed: Update to 0.13.2.

Message ID 9070957d6d2c9f4a0361d1f6e35f0a936643cdb1.1715795372.git.herman@rimm.ee
State New
Headers show
Series Update minizinc and solvers. | expand

Commit Message

Herman Rimm May 15, 2024, 6:01 p.m. UTC
* gnu/packages/maths.scm (chuffed): Update to 0.13.2.

Change-Id: I77fc1ceb9caa42833689fba771010aeb38443e5e
---
 gnu/packages/maths.scm | 30 ++++++++++++++----------------
 1 file changed, 14 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6cb3bdbfb0..2aa7ccaa7a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -309,7 +309,7 @@  (define-public calc
 (define-public chuffed
   (package
     (name "chuffed")
-    (version "0.13.1")
+    (version "0.13.2")
     (source
      (origin
        (method git-fetch)
@@ -317,23 +317,21 @@  (define-public chuffed
              (url "https://github.com/chuffed/chuffed")
              (commit version)))
        (sha256
-        (base32 "1c28q166qh84q4i5wz77fqvw7kld3fmhd245sgdvyxcbjpi2wr0m"))))
+         (base32
+           "164brmwn71p9gb2441kh7b1gzmy2sg7bjv5z00wjs9nw41qc908g"))))
     (build-system cmake-build-system)
-    (synopsis "Lazy clause generation solver")
     (arguments
-     (list
-      #:tests? #f ;no 'test' target
-      #:phases #~(modify-phases %standard-phases
-                   (add-before 'build 'patch-msc
-                     (lambda _
-                       (let ((out #$output))
-                         (substitute* "chuffed.msc"
-                           ;; Replace fzn-chuffed and chuffed paths
-                           ;; before build.
-                           (("\\.\\./../..")
-                            out)
-                           (("\\.\\.")
-                            (string-append out "/share/minizinc")))))))))
+      (list #:tests? #f ;no 'test' target
+            #:phases
+            #~(modify-phases %standard-phases
+                (add-before 'build 'patch-msc
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let ((out (assoc-ref outputs "out")))
+                      (substitute* "chuffed.msc"
+                        (("\\.\\./../..") out)
+                        (("\\.\\.")
+                         (string-append out "/share/minizinc")))))))))
+    (synopsis "Lazy clause generation solver")
     (description
      "Chuffed is a state of the art lazy clause solver designed from the
 ground up with lazy clause generation in mind.  Lazy clause generation