diff mbox series

[bug#71082] gnu: blktrace: Update to 1.3.0.

Message ID 8fba2ff868c2376fd2ee7693573594e0157363c6.1716233408.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#71082] gnu: blktrace: Update to 1.3.0. | expand

Commit Message

Artyom V. Poptsov May 20, 2024, 7:30 p.m. UTC
* gnu/packages/linux.scm (blktrace): Update to 1.3.0.
  [arguments]: Use gexps.

Change-Id: I4e107c8d1f99d5eb44d7f0fd67925cefac36eba9
---
 gnu/packages/linux.scm | 37 ++++++++++++++++++-------------------
 1 file changed, 18 insertions(+), 19 deletions(-)


base-commit: 7881d6085146fefda17ed9eefa133b5b5c97af87

Comments

Ludovic Courtès June 11, 2024, 10:08 p.m. UTC | #1
Hi,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

> * gnu/packages/linux.scm (blktrace): Update to 1.3.0.
>   [arguments]: Use gexps.
>
> Change-Id: I4e107c8d1f99d5eb44d7f0fd67925cefac36eba9

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a9b78a7986..2a85e4b7c8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -63,7 +63,7 @@ 
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021 Ryan Sundberg <ryan@arctype.co>
-;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022-2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2022, 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -5921,12 +5921,12 @@  (define-public libaio
     (license license:lgpl2.1+)))
 
 (define-public blktrace
-  ;; Take a newer commit to get the fix for CVE-2018-10689.
-  (let ((commit "db4f6340e04716285ea56fe26d76381c3adabe58")
+  ;; Take a newer commit to get the latest patches.
+  (let ((commit "b9ea6e507e8849f01d06aa48c0c59c5cee4820be")
         (revision "1"))
     (package
       (name "blktrace")
-      (version (git-version "1.2.0" revision commit))
+      (version (git-version "1.3.0" revision commit))
       (home-page
         "https://git.kernel.org/pub/scm/linux/kernel/git/axboe/blktrace.git")
       (source (origin
@@ -5935,24 +5935,23 @@  (define-public blktrace
                       (url home-page)
                       (commit commit)))
                 (sha256
-                 (base32 "0ah7xn4qnx09k6bm39p69av7d0c8cl6863drv6a1nf914sq1kpgp"))
+                 (base32 "0a4830mlqckbhchar1xcn2w4f24bzb75bigdig5wpm2axl0zc8cq"))
                 (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
-       `(#:make-flags
-         (list ,(string-append "CC=" (cc-for-target))
-               (string-append "prefix=" %output))
-         #:tests? #f                    ; no tests
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)          ; no configure script
-           (add-after 'unpack 'fix-gnuplot-path
-             (lambda* (#:key inputs #:allow-other-keys)
-               (let ((gnuplot (assoc-ref inputs "gnuplot")))
-                 (substitute* "btt/bno_plot.py"
-                   (("gnuplot %s")
-                    (string-append gnuplot "/bin/gnuplot %s")))
-                 #t))))))
+       (list #:make-flags
+             #~(list (string-append "CC=" #$(cc-for-target))
+                     (string-append "prefix=" #$output))
+             #:tests? #f                    ; no tests
+             #:phases
+             #~(modify-phases %standard-phases
+                 (delete 'configure)          ; no configure script
+                 (add-after 'unpack 'fix-gnuplot-path
+                   (lambda* (#:key inputs #:allow-other-keys)
+                     (let ((gnuplot (assoc-ref inputs "gnuplot")))
+                       (substitute* "btt/bno_plot.py"
+                         (("gnuplot %s")
+                          (string-append gnuplot "/bin/gnuplot %s")))))))))
       (inputs
        `(("libaio" ,libaio)
          ("gnuplot" ,gnuplot)