diff mbox series

[bug#69896] gnu: Add emacs-noman.

Message ID 8f9780091f344a39655f715faf32e2903cc4dd19.1710850789.git.suhail@bayesians.ca
State New
Headers show
Series [bug#69896] gnu: Add emacs-noman. | expand

Commit Message

Suhail Singh March 19, 2024, 12:23 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-noman): New variable.

Change-Id: I4ef3de3723025832c6b6eae47de67c3377366602
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: c8556379c3f2d3d095a178858915720f2eebc012

Comments

Dale Mellor April 8, 2024, 3:36 p.m. UTC | #1
I have sent an issue upstream at Github
(https://github.com/andykuszyk/noman.el/issues/5): this package does not seem to
work very well with the GIT command.

I see you are a contributor to the package; if you can I would suggest that when
you bump the version in the code, that you also tag it in the GIT repository,
use that tag in the Guix package definition, and keep the Guix version string
simple (there should be no need to include the GIT fingerprint in the version
number).
Suhail Singh April 9, 2024, 6:11 a.m. UTC | #2
Dale Mellor <guix-devel-0brg6a@rdmp.org> writes:

> I see you are a contributor to the package; if you can I would suggest
> that when you bump the version in the code, that you also tag it in
> the GIT repository

While I have contributed patches, I do not have permission to create
tags upstream.

> use that tag in the Guix package definition

If/when upstream creates tags, I can update the patch to use those
instead.  Till that happens, are there any other changes that would
improve the current patch submission?
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 83e79544ee..a5b9973f0a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5434,6 +5434,30 @@  (define-public emacs-mmt
 Lisp developers who want to write macros with convenience.")
     (license license:gpl3+)))
 
+(define-public emacs-noman
+  (let ((commit "d49ab414c1c6d08a8a9552db27adac0648b282f7")
+        (revision "0"))
+    (package
+      (name "emacs-noman")
+      (home-page "https://github.com/andykuszyk/noman.el")
+      (version (git-version "0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0kcjma1snma17dj32smg75wikwhagn0g14jghhkr8xij429ddsn8"))))
+      (build-system emacs-build-system)
+      (synopsis "Emacs package for browsing CLI command docs without man pages")
+      (description
+       "@code{noman} is an Emacs package that parses command line help from
+flags like @code{--help}, and presents it in an easy-to-navigate Emacs
+buffer.")
+      (license license:gpl3+))))
+
 (define-public emacs-tablist
   (package
     (name "emacs-tablist")