[bug#77764] gnu: Add emacs-jira.

Message ID 8f93ddee259d0ecd5323cf6c7ce3356a2dfd5e1d.1744464248.git.roman@burningswell.com
State New
Headers
Series [bug#77764] gnu: Add emacs-jira. |

Commit Message

Roman Scherer April 12, 2025, 1:27 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-jira): New variable.

Change-Id: I7846eeea3f4f9c06f75d768c7264656a69afdd96
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 63f323fc98fb6e85c48721574aab8e54d95091e5
  

Comments

Cayetano Santos April 12, 2025, 4:52 p.m. UTC | #1
>sam. 12 avril 2025 at 15:27, Roman Scherer <roman@burningswell.com> wrote:

> * gnu/packages/emacs-xyz.scm (emacs-jira): New variable.

> +    (build-system emacs-build-system)

Could you please explicitly disable the tests ?

    (arguments (list #:tests? #f))      ; no tests

This is becoming mandatory in case there are no tests in the package.

Thanks,

C.
  
Roman Scherer April 13, 2025, 8:02 a.m. UTC | #2
Hi Cayetano,

thanks for the review! I sent a v2 that disables the tests.

Can you have another look please?

Thanks, Roman.

Cayetano Santos <csantosb@inventati.org> writes:

>>sam. 12 avril 2025 at 15:27, Roman Scherer <roman@burningswell.com> wrote:
>
>> * gnu/packages/emacs-xyz.scm (emacs-jira): New variable.
>
>> +    (build-system emacs-build-system)
>
> Could you please explicitly disable the tests ?
>
>     (arguments (list #:tests? #f))      ; no tests
>
> This is becoming mandatory in case there are no tests in the package.
>
> Thanks,
>
> C.
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b290ab8d29..31aa7265dd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12277,6 +12277,30 @@  (define-public emacs-jedi
 the locations of docstrings, arguments, and functions.")
     (license license:gpl3+)))
 
+(define-public emacs-jira
+  (package
+    (name "emacs-jira")
+    (version "0.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/unmonoqueteclea/jira.el")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zg7qx05i92xpsa43y9gsxbn08gmzng88dvkva7y70zvrzx58zz2"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-magit
+                             emacs-request
+                             emacs-tablist
+                             emacs-transient))
+    (home-page "https://github.com/unmonoqueteclea/jira.el")
+    (synopsis "Emacs Interface to Jira")
+    (description "This package allows you to visualuze and manipulate Jira
+issues from Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-company-jedi
   (package
     (name "emacs-company-jedi")