diff mbox series

[bug#46503] gnu: gandi.cli: Update to 1.6.

Message ID 8f58f8e1-0cd6-0c0d-e2db-f84a7ae40016@raghavgururajan.name
State Accepted
Headers show
Series [bug#46503] gnu: gandi.cli: Update to 1.6. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Feb. 14, 2021, 5:50 a.m. UTC

Comments

宋文武 Feb. 16, 2021, 9:17 a.m. UTC | #1
Hello!

Raghav Gururajan <rg@raghavgururajan.name> writes:

> [...]
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index 5e0022ac76..cc66434045 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -1454,13 +1454,13 @@ round-robin fashion.")
>  (define-public gandi.cli
>    (package
>      (name "gandi.cli")
> -    (version "1.5")
> +    (version "1.6")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (pypi-uri name version))
>         (sha256
> -        (base32 "110wc9zgxsrvw4yzp21p0ian5lcf7vhcpxhnmsc4fg9pzl2bwxd5"))))
> +        (base32 "1h36jahbp7273wn3yd747kbiwjc0bm3sja67bcxdsd54ln0vyndg"))))
>      (build-system python-build-system)
>      (arguments
>       `(#:phases
> @@ -1484,10 +1484,14 @@ round-robin fashion.")
>                 #t))))))
>      (native-inputs
>       `(("python-docutils" ,python-docutils)   ; for rst2man.py
> +       ("python-mock" ,python-mock)

As see in setup.py, python-mock is not needed here, since this package
use 'unittest.mock' with Python 3.

> +       ("python-pytest" ,python-pytest)
>         ("python-pytest-cov" ,python-pytest-cov)
> +       ("python-setuptools" ,python-setuptools)

python-setuptools is not needed too, since our python package have it
builtin.
>         ("python-tox" ,python-tox)))
>      (inputs
> -     `(("openssl" ,openssl)
> +     `(("openssh" ,openssh)

openssh need to be a 'propagated-input', or better we cloud patch
'gandi/cli/modules/iass.py' to execute commands with absolute paths.
> +       ("openssl" ,openssl)
>         ("python-click" ,python-click)
>         ("python-ipy" ,python-ipy)
>         ("python-pyyaml" ,python-pyyaml)

I made above said changes and pushed, thank you!
diff mbox series

Patch

From fa4e19d77c5d5c7510652c11387455caa23f2896 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Sun, 14 Feb 2021 00:46:30 -0500
Subject: [PATCH 3/3] gnu: gandi.cli: Update to 1.6.

* gnu/packages/networking.scm (gandi.cli) [version]: Update to 1.6.
[native-inputs]: Add python-mock, python-pytest and python-setuptools.
[inputs]: Add openssh.
---
 gnu/packages/networking.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5e0022ac76..cc66434045 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1454,13 +1454,13 @@  round-robin fashion.")
 (define-public gandi.cli
   (package
     (name "gandi.cli")
-    (version "1.5")
+    (version "1.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri name version))
        (sha256
-        (base32 "110wc9zgxsrvw4yzp21p0ian5lcf7vhcpxhnmsc4fg9pzl2bwxd5"))))
+        (base32 "1h36jahbp7273wn3yd747kbiwjc0bm3sja67bcxdsd54ln0vyndg"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1484,10 +1484,14 @@  round-robin fashion.")
                #t))))))
     (native-inputs
      `(("python-docutils" ,python-docutils)   ; for rst2man.py
+       ("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)
        ("python-pytest-cov" ,python-pytest-cov)
+       ("python-setuptools" ,python-setuptools)
        ("python-tox" ,python-tox)))
     (inputs
-     `(("openssl" ,openssl)
+     `(("openssh" ,openssh)
+       ("openssl" ,openssl)
        ("python-click" ,python-click)
        ("python-ipy" ,python-ipy)
        ("python-pyyaml" ,python-pyyaml)
-- 
2.30.0