diff mbox series

[bug#71914,08/10] gnu: Add rust-pyo3-macros-0.21.

Message ID 8f5311fba8e591543e7d8e544555b2efceb4bc92.1719992277.git.mcsinyx@disroot.org
State New
Headers show
Series gnu: Add python-nh3. | expand

Commit Message

ashish.is--- via Guix-patches" via July 3, 2024, 7:57 a.m. UTC
* gnu/packages/crates-io.scm (rust-pyo3-macros-0.21): New variable.
(rust-pyo3-macros-0.20): Inherit from rust-pyo3-macros-0.21.
Update to 0.20.3.

Change-Id: I90c07ee66aff098250345d11d120e1c62203b7e0
---
 gnu/packages/crates-io.scm | 34 +++++++++++++++++++++++++++-------
 1 file changed, 27 insertions(+), 7 deletions(-)

Comments

ashish.is--- via Guix-patches" via July 3, 2024, 8:11 a.m. UTC | #1
On 2024-07-03 at 16:57+09:00, Nguyễn Gia Phong wrote:
> * gnu/packages/crates-io.scm (rust-pyo3-macros-0.20):
> Inherit from rust-pyo3-macros-0.21.
> Update to 0.20.3.
> ---
> +(define-public rust-pyo3-macros-0.20
> +  (package
> +    (inherit rust-pyo3-macros-0.21)
[snip]
> +    (arguments
> +     `(#:cargo-inputs
> +       (("rust-proc-macro2" ,rust-proc-macro2-1)
> +        ("rust-pyo3-macros-backend" ,rust-pyo3-macros-backend-0.20)
> +        ("rust-quote" ,rust-quote-1)
> +        ("rust-syn" ,rust-syn-2))))))

I just realized that all pyo3-* 0.20 use the same cargo-inputs as 0.21.
Should I send v2 for all patches or just 05 to 08?
Efraim Flashner July 3, 2024, 9 a.m. UTC | #2
On Wed, Jul 03, 2024 at 05:11:43PM +0900, guix-patches--- via wrote:
> On 2024-07-03 at 16:57+09:00, Nguyễn Gia Phong wrote:
> > * gnu/packages/crates-io.scm (rust-pyo3-macros-0.20):
> > Inherit from rust-pyo3-macros-0.21.
> > Update to 0.20.3.
> > ---
> > +(define-public rust-pyo3-macros-0.20
> > +  (package
> > +    (inherit rust-pyo3-macros-0.21)
> [snip]
> > +    (arguments
> > +     `(#:cargo-inputs
> > +       (("rust-proc-macro2" ,rust-proc-macro2-1)
> > +        ("rust-pyo3-macros-backend" ,rust-pyo3-macros-backend-0.20)
> > +        ("rust-quote" ,rust-quote-1)
> > +        ("rust-syn" ,rust-syn-2))))))
> 
> I just realized that all pyo3-* 0.20 use the same cargo-inputs as 0.21.
> Should I send v2 for all patches or just 05 to 08?

They use the 0.20 version of the inputs, not the 0.21 version of the
inputs, so they have different cargo-inputs.
ashish.is--- via Guix-patches" via July 3, 2024, 9:12 a.m. UTC | #3
On 2024-07-03 at 12:00+03:00, Efraim Flashner wrote:
> On Wed, Jul 03, 2024 at 05:11:43PM +0900, Nguyễn Gia Phong wrote:
> > On 2024-07-03 at 16:57+09:00, Nguyễn Gia Phong wrote:
> > I just realized that all pyo3-* 0.20 use the same cargo-inputs
> > as 0.21.  Should I send v2 for all patches or just 05 to 08?
>
> They use the 0.20 version of the inputs, not the 0.21 version of the
> inputs, so they have different cargo-inputs.

Sorry, my bad, that only applies for the 3 other pyo3-*
(I removed their arguments and rust-pyo3@0.20 built w/o any error).

Either way, what's the general etiquette for sending revisions
of a subset of the patch series?
Efraim Flashner July 3, 2024, 9:27 a.m. UTC | #4
On Wed, Jul 03, 2024 at 06:12:51PM +0900, Nguyễn Gia Phong wrote:
> On 2024-07-03 at 12:00+03:00, Efraim Flashner wrote:
> > On Wed, Jul 03, 2024 at 05:11:43PM +0900, Nguyễn Gia Phong wrote:
> > > On 2024-07-03 at 16:57+09:00, Nguyễn Gia Phong wrote:
> > > I just realized that all pyo3-* 0.20 use the same cargo-inputs
> > > as 0.21.  Should I send v2 for all patches or just 05 to 08?
> >
> > They use the 0.20 version of the inputs, not the 0.21 version of the
> > inputs, so they have different cargo-inputs.
> 
> Sorry, my bad, that only applies for the 3 other pyo3-*
> (I removed their arguments and rust-pyo3@0.20 built w/o any error).
> 
> Either way, what's the general etiquette for sending revisions
> of a subset of the patch series?

I don't think we have a consensus. On one hand re-sending unchanged
patches is "wasteful", on the other hand it makes it easier to work on a
set of patches (or a revision of patches) in one go.

I think I normally end up with a single updated patch if there's a
change to only one patch, but otherwise I normally send out a whole new
set and then in 0000-v2 I mention what changes there are compared to the
previous version.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index acf1fc8f83ea..a0e99340ccd9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -51564,29 +51564,49 @@  (define-public rust-pyo3-macros-backend-0.15
         ("rust-syn" ,rust-syn-1))))
     (native-inputs (list python))))
 
-(define-public rust-pyo3-macros-0.20
+(define-public rust-pyo3-macros-0.21
   (package
     (name "rust-pyo3-macros")
-    (version "0.20.2")
+    (version "0.21.2")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "pyo3-macros" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1lsfyx1shdyi7zybs3maakh2h3zsij3l5wap35qval0dwjs3ixq5"))))
+        (base32 "0g65z9yj2iffjrkrkzan9hwhhj7rrchh7lfv64dy30h6zill1cvp"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
-                       ("rust-pyo3-macros-backend" ,rust-pyo3-macros-backend-0.20)
-                       ("rust-quote" ,rust-quote-1)
-                       ("rust-syn" ,rust-syn-2))))
+     `(#:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-pyo3-macros-backend" ,rust-pyo3-macros-backend-0.21)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-2))))
     (home-page "https://github.com/pyo3/pyo3")
     (synopsis "Proc macros for PyO3")
     (description
      "This package provides compiler macros for use with PyO3.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-pyo3-macros-0.20
+  (package
+    (inherit rust-pyo3-macros-0.21)
+    (name "rust-pyo3-macros")
+    (version "0.20.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pyo3-macros" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0n61s98qb2qc1wlda3bz4r0wi0vsr9p4lj2yr5g0bf01z8hcf1bk"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-pyo3-macros-backend" ,rust-pyo3-macros-backend-0.20)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-2))))))
+
 (define-public rust-pyo3-macros-0.19
   (package
     (inherit rust-pyo3-macros-0.20)