[bug#76513,rust-team,31/77] gnu: Add rust-hypher-0.1.

Message ID 8f4a4edae1184e8f834e41f9785795da0e03ad49.1740340805.git.wongandj@icloud.com
State New
Headers
Series Add module (gnu packages typst) and packages |

Commit Message

Andrew Wong Feb. 23, 2025, 8:21 p.m. UTC
  * gnu/packages/crates-io.scm (rust-hypher-0.1): New variable.

Change-Id: I9c00d1b86e89756f9c01ed595036f253b78a62a1
---
 gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5c510655d4..56a76b99ce 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33257,6 +33257,26 @@  (define-public rust-hyphenation-0.8
      "This package provides a Knuth-Liang hyphenation for a variety of languages.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-hypher-0.1
+  (package
+    (name "rust-hypher")
+    (version "0.1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hypher" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0ra2kxbpi033jy42wkr7m7rgg6yhy69xad0hmc0z43936xbas91v"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))
+    (home-page "https://github.com/typst/hypher")
+    (synopsis "hypher separates words into syllables")
+    (description
+     "This package provides hypher separates words into syllables.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-hyphenation-commons-0.8
   (package
     (name "rust-hyphenation-commons")