[bug#75516] gnu: Add bchunk.
Commit Message
* gnu/packages/cdrom.scm (bchunk): New variable.
Change-Id: I0fbc7255fcb4cf5b52c52092a4f56b06511a2294
---
gnu/packages/cdrom.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
base-commit: bde32a3d88482f6e0b2f260174914c020a7c6166
@@ -210,6 +210,37 @@ (define-public xorriso
files.")
(license gpl3+)))
+(define-public bchunk
+ (package
+ (name "bchunk")
+ (version "1.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hessu/bchunk")
+ (commit
+ (string-append "release/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0amhc196ibg7gj2iki0z9kykvcm85jxpbnkcmk2jxj3hni242n60"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "bchunk" (string-append out "/bin"))
+ (install-file "bchunk.1" (string-append out "/share/man/man.1"))))))))
+ (home-page "http://he.fi/bchunk/")
+ (synopsis "Bin/cue to ISO image converter")
+ (description "@command{cdrecord} converts a CD image in a \".bin / .cue\"
+format (sometimes \".raw / .cue\") to a set of .iso and .cdr tracks.")
+ (license gpl2)))
+
(define-public cdparanoia
(package
(name "cdparanoia")