diff mbox series

[bug#67278] gnu: Add vim-jedi.

Message ID 8f3a4979d85b9157f8008bdfcadce88851eeb941.1700399958.git.mcsinyx@disroot.org
State New
Headers show
Series [bug#67278] gnu: Add vim-jedi. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Nov. 19, 2023, 1:19 p.m. UTC
* gnu/packages/vim.scm (vim-jedi): New variable.

Change-Id: I2656837686866961266b093cd6b4a4d528f5f684
---
 gnu/packages/vim.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 5cad6f721b8884b612178896f06cd69d5839402c

Comments

Efraim Flashner Nov. 26, 2023, 10:09 a.m. UTC | #1
I looked around the sources and I didn't see a good spot to try to wrap
the plugin with python-jedi so we wouldn't have to propagate it.

I also renamed the package to vim-jedi-vim. Patch pushed! Thanks.

On Sun, Nov 19, 2023 at 10:19:19PM +0900, guix-patches--- via wrote:
> * gnu/packages/vim.scm (vim-jedi): New variable.
> 
> Change-Id: I2656837686866961266b093cd6b4a4d528f5f684
> ---
>  gnu/packages/vim.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
> 
> diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
> index 469c8b64cbe6..d10308959687 100644
> --- a/gnu/packages/vim.scm
> +++ b/gnu/packages/vim.scm
> @@ -1423,3 +1423,25 @@ (define-public vim-nerdcommenter
>  operations and styles which are invoked via key mappings and a menu.  These
>  operations are available for most filetypes.")
>      (license license:cc0)))
> +
> +(define-public vim-jedi
> +  (package
> +    (name "vim-jedi")
> +    (version "0.11.2")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +              (url "https://github.com/davidhalter/jedi-vim")
> +              (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +         (base32 "03fj7f5cpchrdmz9szal6fdg05wdwb0j6260nnyp37nmpcpn13yc"))))
> +    (build-system vim-build-system)
> +    (arguments (list #:plugin-name "jedi-vim"))
> +    (propagated-inputs (list python-jedi))
> +    (home-page "https://github.com/davidhalter/jedi-vim")
> +    (synopsis "Jedi autocompletion library for Vim")
> +    (description
> +      "@code{jedi-vim} is a VIM binding to the autocompletion library Jedi.")
> +    (license license:expat)))
> 
> base-commit: 5cad6f721b8884b612178896f06cd69d5839402c
> -- 
> 2.41.0
> 
> 
> 
>
vasilii.smirnov--- via Guix-patches" via Nov. 27, 2023, 4:04 p.m. UTC | #2
On 2023-11-26 at 12:09+02:00, Efraim Flashner wrote:
> I looked around the sources and I didn't see a good spot to try to wrap
> the plugin with python-jedi so we wouldn't have to propagate it.
>
> I also renamed the package to vim-jedi-vim. Patch pushed! Thanks.

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 469c8b64cbe6..d10308959687 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1423,3 +1423,25 @@  (define-public vim-nerdcommenter
 operations and styles which are invoked via key mappings and a menu.  These
 operations are available for most filetypes.")
     (license license:cc0)))
+
+(define-public vim-jedi
+  (package
+    (name "vim-jedi")
+    (version "0.11.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/davidhalter/jedi-vim")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+         (base32 "03fj7f5cpchrdmz9szal6fdg05wdwb0j6260nnyp37nmpcpn13yc"))))
+    (build-system vim-build-system)
+    (arguments (list #:plugin-name "jedi-vim"))
+    (propagated-inputs (list python-jedi))
+    (home-page "https://github.com/davidhalter/jedi-vim")
+    (synopsis "Jedi autocompletion library for Vim")
+    (description
+      "@code{jedi-vim} is a VIM binding to the autocompletion library Jedi.")
+    (license license:expat)))