diff mbox series

[bug#66566,3/3] gnu: Remove emacs-poke.

Message ID 8f333d4832350044e64b9107af6fa28c4468ec69.1697391346.git.mirai@makinata.eu
State New
Headers show
Series Refactor GNU poke definition. | expand

Commit Message

Bruno Victal Oct. 15, 2023, 5:47 p.m. UTC
This naming conflicts with the ELPA 'poke' package, a emacs interface to
GNU poke.

* gnu/packages/engineering.scm (emacs-poke): Remove variable.
---
 gnu/packages/engineering.scm | 18 ------------------
 1 file changed, 18 deletions(-)

Comments

Efraim Flashner Oct. 16, 2023, 9:23 a.m. UTC | #1
Does it make more sense to either replace this package with the ELPA
poke package, or to deprecate this package and have it point back at
poke?

On Sun, Oct 15, 2023 at 06:47:08PM +0100, Bruno Victal wrote:
> This naming conflicts with the ELPA 'poke' package, a emacs interface to
> GNU poke.
> 
> * gnu/packages/engineering.scm (emacs-poke): Remove variable.
> ---
>  gnu/packages/engineering.scm | 18 ------------------
>  1 file changed, 18 deletions(-)
> 
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index 112417b30e..a00c098f90 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -3271,24 +3271,6 @@ (define-public poke
>  data structures and to operate on them.")
>      (license license:gpl3+)))
>  
> -(define-public emacs-poke
> -  (package
> -    (inherit poke)
> -    (name "emacs-poke")
> -    (build-system emacs-build-system)
> -    (arguments
> -     (list
> -       #:phases
> -       #~(modify-phases %standard-phases
> -           (add-before 'expand-load-path 'change-working-directory
> -             (lambda _ (chdir "etc"))))))
> -    (inputs '())
> -    (native-inputs '())
> -    (synopsis "GNU Poke major modes for Emacs")
> -    (description
> -     "This package provides two Emacs major modes for working with GNU Poke:
> -@code{Poke Ras mode} and @code{Poke Map mode}.")))
> -
>  (define-public pcb2gcode
>    (package
>     (name "pcb2gcode")
> -- 
> 2.41.0
> 
> 
> 
>
Bruno Victal Oct. 16, 2023, 2:57 p.m. UTC | #2
Hi Efraim,

On 2023-10-16 10:23, Efraim Flashner wrote:
> Does it make more sense to either replace this package with the ELPA
> poke package, or to deprecate this package and have it point back at
> poke?

I'd say it makes sense to replace it with the ELPA one to avoid confusion,
though I didn't do so here since I'm not planning on using it (yet) and
thus can't vouch whether it works or not.
Ludovic Courtès Oct. 20, 2023, 10:20 p.m. UTC | #3
Hi!

Bruno Victal <mirai@makinata.eu> skribis:

> On 2023-10-16 10:23, Efraim Flashner wrote:
>> Does it make more sense to either replace this package with the ELPA
>> poke package, or to deprecate this package and have it point back at
>> poke?
>
> I'd say it makes sense to replace it with the ELPA one to avoid confusion,
> though I didn't do so here since I'm not planning on using it (yet) and
> thus can't vouch whether it works or not.

But since ‘poke’ now provides the Emacs mode, should we:

  (define-public emacs-poke
    (deprecated-package "emacs-poke" poke))

for now?

(I can do it on your behalf, let me know.)

Ludo’.
Bruno Victal Oct. 21, 2023, 8:58 a.m. UTC | #4
Hi Ludo’,

On 2023-10-20 23:20, Ludovic Courtès wrote:
> But since ‘poke’ now provides the Emacs mode, should we:
> 
>   (define-public emacs-poke
>     (deprecated-package "emacs-poke" poke))
> 
> for now?
> 
> (I can do it on your behalf, let me know.)

Go ahead! I think there's no harm in doing this but do leave a comment
above it indicating that the package can be substituted anytime in the
future with the ELPA 'poke'.
Ludovic Courtès Oct. 21, 2023, 2:08 p.m. UTC | #5
Hi Bruno,

Bruno Victal <mirai@makinata.eu> skribis:

> On 2023-10-20 23:20, Ludovic Courtès wrote:
>> But since ‘poke’ now provides the Emacs mode, should we:
>> 
>>   (define-public emacs-poke
>>     (deprecated-package "emacs-poke" poke))
>> 
>> for now?
>> 
>> (I can do it on your behalf, let me know.)
>
> Go ahead! I think there's no harm in doing this but do leave a comment
> above it indicating that the package can be substituted anytime in the
> future with the ELPA 'poke'.

Done, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 112417b30e..a00c098f90 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3271,24 +3271,6 @@  (define-public poke
 data structures and to operate on them.")
     (license license:gpl3+)))
 
-(define-public emacs-poke
-  (package
-    (inherit poke)
-    (name "emacs-poke")
-    (build-system emacs-build-system)
-    (arguments
-     (list
-       #:phases
-       #~(modify-phases %standard-phases
-           (add-before 'expand-load-path 'change-working-directory
-             (lambda _ (chdir "etc"))))))
-    (inputs '())
-    (native-inputs '())
-    (synopsis "GNU Poke major modes for Emacs")
-    (description
-     "This package provides two Emacs major modes for working with GNU Poke:
-@code{Poke Ras mode} and @code{Poke Map mode}.")))
-
 (define-public pcb2gcode
   (package
    (name "pcb2gcode")